Closed Bug 1108252 Opened 5 years ago Closed 5 years ago

Remove Firefox Search activity launcher icon

Categories

(Firefox for Android :: General, defect)

35 Branch
All
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 37
Tracking Status
firefox34 --- unaffected
firefox35 + fixed
firefox36 --- fixed
firefox37 --- verified
fennec 35+ ---

People

(Reporter: aaronmt, Assigned: rnewman)

Details

(Keywords: ux-userfeedback)

Attachments

(1 file)

Bug 1042958 added a launcher icon for the search activity. Based on feedback on Google Play, as expected, people don't want extra cruft populating their application listing. This crash report comment [1] thinks the search activity launcher icon is a virus.

[1] https://crash-stats.mozilla.com/report/index/17b3b0af-1ac1-42a7-9289-48f402141206

E.g, 1 star comments

  Extra search Integrated extra search is annoying. Extra shortcut is annoying. Remove or let is turn off annoying unnecessary stuff. If I want to search using fire fox, I'd open Firefox.

 
  Thumbs up Runs better than the alpha version !! Deleted because firefox search is unnecessary

  Why do some bitch decides how to include a search engine app?

  No thanks for making me lose everything, my tabs, bookmarks etc by adding an extra search app which i do not need. It uninstalled everything along with it although it was just the search I wanted to delete.. Damn it!!!

  No thanks I don't mind yahoo being the default search platform for Firefox but at least give me the option to change it to google. And most importantly, get rid of the search icon in the app tray. Why does such a minor feature need its dedicated icon? Why not just integrate it into the address bar like google or opera?

[Tracking Requested - why for this release]: user feedback
 Firefox search NO. Just no. It's ugly, uncustomisable and completely useless to have a search app with 0 extra features outside the main app. Get rid of it.

 Firefox search w/yahoo? I did not ask for a second app, especially one with Yahoo. No thank you. I'll move back to 5 stars when this junk is gone.

 WHAT??? Get rid of Yahoo search. I don't need a mandatory yahoo search app as part of Firefox. Surely it's a bit redundant on all android devices, but especially so on my Nexus 5. Horrible decision. Get rid of it!

 How to remove the Firefox beta search

 Jeez Remove the search icon from launcher wtf man
Hardware: ARM → All
Version: Firefox 37 → Firefox 35
(In reply to Aaron Train [:aaronmt] from comment #0)
> Bug 1042958 added a launcher icon…

I think that bug was actually just for the *icon*. The patch there was on top of whatever already added the manifest entry.
I do think we should do this -- our fallback for old devices without a proper search hook is _launching Firefox_, not offering an additional search entry point.

I think users have a strong sense of ownership over the things they put in their launcher, and we're falling afoul of that here.

If we want to provide a launcher-ish icon for the search activity, we can add one at runtime, in the same way that we add home screen shortcuts.
Attachment #8532826 - Flags: review?(mark.finkle)
Assignee: nobody → rnewman
Status: NEW → ASSIGNED
Karen should feedback. I don't mind removing the icon since we also provide a widget. That said, the feedback alone is not convincing enough. Just sounds like rude, aggro trolling.
Flags: needinfo?(krudnitski)
The problem is as follow:

1. bloatware on Android is so common that people hate being forced apps on them. Icon = app in their mind.

2. Yahoo is not really popular. Since we default search to Yahoo, people think it is Yahoo. Bad timing (ie we just announced the new deal and blam). Even with an icon that looks vendor neutral.
I read the outrage on twitter as "Firefox for Android come with a Yahoo search app". I hadn't updated yet and really thought it was a Y! Search app.
Also see bug 1108430 (I filed) that outline a problem that make people think of this.

3. I personally don't see a reason for the search icon in the app listing. Many user seems to think the same.
(In reply to Hubert Figuiere [:hub] from comment #5)
> The problem is as follow:
> 
> 1. bloatware on Android is so common that people hate being forced apps on
> them. Icon = app in their mind.

Removing the Icon won't remove the code or the activity. 

> 2. Yahoo is not really popular. Since we default search to Yahoo, people
> think it is Yahoo. Bad timing (ie we just announced the new deal and blam).
> Even with an icon that looks vendor neutral.
> I read the outrage on twitter as "Firefox for Android come with a Yahoo
> search app". I hadn't updated yet and really thought it was a Y! Search app.
> Also see bug 1108430 (I filed) that outline a problem that make people think
> of this.

Yahoo is the default now. People will need to get used to it, and learn how to switch engines if they wish to use something else.

> 3. I personally don't see a reason for the search icon in the app listing.
> Many user seems to think the same.

Why start Firefox when all you wan to do is search for something new? Google obviously feels that faster access to a search engine is important and does not force people to start Chrome just to search.

I'd rather switch the Icon to something more Firefoxy and leave it in place.
NI'ing UX to consider an Icon design more aligned to Firefox. I don't think we should do a knee-jerk response to some users' knee-jerk responses.
Flags: needinfo?(randersen)
Flags: needinfo?(dhenein)
Flags: needinfo?(alam)
(In reply to Mark Finkle (:mfinkle) from comment #6)
> > The problem is as follow:
> > 
> > 1. bloatware on Android is so common that people hate being forced apps on
> > them. Icon = app in their mind.
> 
> Removing the Icon won't remove the code or the activity. 

Which is fine. Not sure exactly the purpose of the activity, but the icon in the app list is what people are being confused / complain about.

> > 2. Yahoo is not really popular. Since we default search to Yahoo, people
> > think it is Yahoo. Bad timing (ie we just announced the new deal and blam).
> > Even with an icon that looks vendor neutral.
> > I read the outrage on twitter as "Firefox for Android come with a Yahoo
> > search app". I hadn't updated yet and really thought it was a Y! Search app.
> > Also see bug 1108430 (I filed) that outline a problem that make people think
> > of this.
> 
> Yahoo is the default now. People will need to get used to it, and learn how
> to switch engines if they wish to use something else.

True. But then bug 1108430 is about making the configurability in there. Would mitigate the problem by make it clear it is not "Yahoo search" but rather the browser search.

> > 3. I personally don't see a reason for the search icon in the app listing.
> > Many user seems to think the same.
> 
> Why start Firefox when all you wan to do is search for something new? Google
> obviously feels that faster access to a search engine is important and does
> not force people to start Chrome just to search.

Not completely convinced about that specific argument. Isn't that what the search bar on Android does (being by default to Google - not even sure that can be changed)? Also two icons instead of one, it is confusing. But again, I didn't do the UX.
 
> I'd rather switch the Icon to something more Firefoxy and leave it in place.

And implement what is suggested in bug 1108430. Why shall one launch the browser to change the search engine of the search app. This goes hand in hand with your argument about what this "app" is needed.

'knee-jerk response' isn't really the appropriate qualifier for this issue.
I think there are indeed some responses that are based off of the yahoo default change and equating that with the additional method for initiating search with Firefox. We have to ensure we're not reacting to negative feelings towards yahoo at the expense of allowing easier access to a truly important activity [search] utilizing the user's preferred browser choice [Firefox].

Pragmatically, I can see that having that extra icon may be confusing, regardless of the design. Come release, the icon name would be 'Firefox Search' which may make things a little easier to interpret, but having two icons install with one browser download may not make sense to a lot of people.

I would like to clarify two points, one I'm more sure than the other:
- if we remove the icon, our widget will still be found in the widget library? (I feel like the answer is 'yes' here.)
- if we remove the icon, will the user be prompted which browser to use when 'swiping up' from the bottom?

I am not in any agreement to change the design of the activity itself, however. It's the foundation for a lot of really interesting work ahead, and will also bear witness to some different designs UX has been looking into around search provider choice etc.
Flags: needinfo?(krudnitski)
(In reply to Karen Rudnitski [:kar] from comment #9)
> I would like to clarify two points, one I'm more sure than the other:
> - if we remove the icon, our widget will still be found in the widget
> library? (I feel like the answer is 'yes' here.)

Yes.

> - if we remove the icon, will the user be prompted which browser to use when
> 'swiping up' from the bottom?

When you swipe up you can still complete the action using Google/Firefox Search
(In reply to Aaron Train [:aaronmt] from comment #10)
> (In reply to Karen Rudnitski [:kar] from comment #9)
> > I would like to clarify two points, one I'm more sure than the other:
> > - if we remove the icon, our widget will still be found in the widget
> > library? (I feel like the answer is 'yes' here.)
> 
> Yes.
> 
> > - if we remove the icon, will the user be prompted which browser to use when
> > 'swiping up' from the bottom?
> 
> When you swipe up you can still complete the action using Google/Firefox
> Search

Yep. If the extra icon feels like "bloatware" we can remove it and Firefox Search would still be accessible from swipe and the widget (if added to the homescreen).
In that case, my recommendation is that the prudent step is to remove the search icon in this phase of the search iterations we have on the books. We can revisit this decision when we continue to evolve the activity as we plan on doing so it seems more obvious as to the value we are bringing to users.
Comment on attachment 8532826 [details] [diff] [review]
Remove launcher icon for search activity. v1

Sounds like some consensus
Attachment #8532826 - Flags: review?(mark.finkle) → review+
We can pull UX in for any followup work. Removing NIs.
Flags: needinfo?(randersen)
Flags: needinfo?(dhenein)
Flags: needinfo?(alam)
Verified that with a local build there's no search icon, but the swipe-up function still works.
Comment on attachment 8532826 [details] [diff] [review]
Remove launcher icon for search activity. v1

Approval Request Comment
[Feature/regressing bug #]:
  Introduction of search activity, which is reaching release channels.

[User impact if declined]:
  Extra icon in launcher, which is confusing to users.

[Describe test coverage new/current, TBPL]:
  Manual testing. 

[Risks and why]: 
  Makes users unhappy. Should be zero risk.

[String/UUID change made/needed]:
  None.
Attachment #8532826 - Flags: approval-mozilla-beta?
Attachment #8532826 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/5f6269fe747a
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 37
Attachment #8532826 - Flags: approval-mozilla-beta?
Attachment #8532826 - Flags: approval-mozilla-beta+
Attachment #8532826 - Flags: approval-mozilla-aurora?
Attachment #8532826 - Flags: approval-mozilla-aurora+
Verified as fixed in 37.0a1 2014-12-10.
Device: Samsung Galaxy S5 (Android 4.4.2).
https://hg.mozilla.org/releases/mozilla-beta/rev/3b0d7904c0dc
tracking-fennec: ? → 35+
Summary: Consider removing Firefox Search activity launcher icon → Remove Firefox Search activity launcher icon
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.