Investigate sweeping more JSObjects incrementally

RESOLVED DUPLICATE of bug 1352430

Status

()

RESOLVED DUPLICATE of bug 1352430
4 years ago
a year ago

People

(Reporter: jonco, Unassigned)

Tracking

({perf})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Currently we sweep any JSObject that cannot be swept on the background thread in the first slice of sweeping for a zone group, which has the potential to produce large pause times and causes us to overrun our slice budget.

One reason we do this is because DOM object finalizers must all be run in this slice so they can clear their wrapper cache entries and prevent the program from observing dead objects in cache before the entry is cleared.

This particular problem could be solved by putting a read barrier on the wrapper cache.  This would allow us to sweep those objects incrementally on the foreground thread.

We should investigate this possibility.

Updated

2 years ago
Keywords: perf
(Reporter)

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1352430
You need to log in before you can comment on or make changes to this bug.