about:preferences#search oneClickProvidersList doesn't grow to accommodate more providers or scroll

RESOLVED WORKSFORME

Status

()

Firefox
Search
RESOLVED WORKSFORME
3 years ago
8 months ago

People

(Reporter: Gregg Lind (Fx Strategy and Insights - Shield - Heartbeat ), Unassigned)

Tracking

34 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

To reproduce:

1.  Add provider from `about:preferences#search` "add more providers".  (I chose youtube)
2.  OBSERVE: 
  a. oneClickProvidersList doesn't show YouTube
  b. oneClickProvidersList doesn't scroll

Suggested fix:

oneClickProvidersList should grow to show more (?) or all (?) providers.
Does it show up un-selected by default in the "One-click search engines" list?
(So, weird... it 'eventually' does.  Maybe after new window made?  

For now it's a Heisenbug :)  I will dig a bit more.  Anyway maybe play with adding engines and see if it Does the Right Thing, and write down what that Should Be!

Thanks!

Comment 3

3 years ago
Created attachment 8548636 [details]
Buggy display of search providers selection

Possibly related: I have several additional search providers installed, and just upgraded to Fx35 today (and had incontent-prefs pref'ed on for a while now).  When Fx switched my default provider to Yahoo, I went to preferences to change it back and got this.  When I turn off in-content prefs, I get a window where all the controls are properly sized to contain their contents.  When I turn it back on, and open a new window and then open about:preferences#search, I get this again.  Ditto if I restart Fx -- so this at least is not a Heisenbug for me.
I believe that's unrelated, Ben.  Could you file it as a new bug, and CC florian@queze.net?
Possibly related: bug 1113629.
I cannot reproduce this. Is this still a bug?
Flags: needinfo?(glind)
Please reopen if you can still reproduce, thanks!
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
Flags: needinfo?(glind)
You need to log in before you can comment on or make changes to this bug.