If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Getting software error while login in to Bugzilla ver 5.1 (www.landfill.bugzilla.org/bugzilla-tip)

RESOLVED DUPLICATE of bug 1108374

Status

()

Bugzilla
bugzilla.org
RESOLVED DUPLICATE of bug 1108374
3 years ago
3 years ago

People

(Reporter: Sridhar, Unassigned)

Tracking

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; Trident/7.0; .NET CLR 2.0.50727; SLCC2; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.3; .NET4.0C; .NET4.0E; rv:11.0) like Gecko

Steps to reproduce:

I have created test app in C# to access bugzilla through xml-rpc. 
For my testing I am using "www.landfill.bugzilla.org/bugzilla-tip" (Latest bugzilla version 5.1 openly available to all for testing).


Actual results:


During login, I am getting the below error.
----------------------
<h1>Software error:</h1>
<pre>Can't use string (&quot;&quot;) as a subroutine ref while &quot;strict refs&quot; in use at lib/SOAP/Transport/HTTP.pm line 384.
</pre>
<p>
For help, please send mail to the webmaster (<a href="mailto:webmaster@bugzilla.org">webmaster@bugzilla.org</a>), giving this error message 
and the time and date of the error.
</p>
----------------------

For the initial login request, the input xml beeing sent to "www.landfill.bugzilla.org/bugzilla-tip" given below.

<?xml version="1.0"?>
<methodCall>
  <methodName>User.login</methodName>
  <params>
    <param>
      <value>
        <struct>
          <member>
            <name>login</name>
            <value>
              <string>sridhar.mahadevan@wipro.com</string>
            </value>
          </member>
          <member>
            <name>password</name>
            <value>
              <string>xxxx</string>
            </value>
          </member>
        </struct>
      </value>
    </param>
  </params>
</methodCall>




Expected results:

Note: The same request sent to Bugzilla version 4.4.x (www.landfill.bugzilla.org/bugzilla-4.4-branch/), It works fine. In 4.4 branch I am able to login and create the ticket.
(Reporter)

Updated

3 years ago
Severity: normal → blocker

Updated

3 years ago
Severity: blocker → normal
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1108374
You need to log in before you can comment on or make changes to this bug.