Profiler does not start again. [frequently stops working]

RESOLVED WORKSFORME

Status

DevTools
Performance Tools (Profiler/Timeline)
RESOLVED WORKSFORME
4 years ago
a month ago

People

(Reporter: Liam Wilson, Unassigned)

Tracking

34 Branch
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:34.0) Gecko/20100101 Firefox/34.0
Build ID: 20141127111021

Steps to reproduce:

Open the profiler in devtools, run the profiler, close devtools, reopen the profiler and attempt to run the profiler again.


Actual results:

Profiler would not start again. Got the following error at the console:

A coding exception was thrown and uncaught in a Task.

Full message: TypeError: "to" is read-only
Full stack: ProfilerConnection.prototype._request@resource://gre/modules/commonjs/toolkit/loader.js -> resource:///modules/devtools/profiler/shared.js:154:7
ProfilerFront.prototype.startRecording<@resource://gre/modules/commonjs/toolkit/loader.js -> resource:///modules/devtools/profiler/shared.js:356:13
TaskImpl_run@resource://gre/modules/Task.jsm:314:40
Handler.prototype.process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:865:23
this.PromiseWalker.walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:744:7



Expected results:

Profiler should keep working. The only way to make the profiler work again is to restart Firefox.

Comment 1

4 years ago
bug: firefox-34.0.en-US.linux64
bug: firefox-34.0.5.en-US.linux64
wfm: 2014-09-08-00-40-02-mozilla-aurora-firefox-34.0a2.en-US.linux-x86_64
wfm: 2014-09-30-00-40-06-mozilla-aurora-firefox-34.0a2.en-US.linux-x86_64
wfm: 2014-07-23-03-02-02-mozilla-central-firefox-34.0a1.ru.linux-x86_64
wfm: 2014-08-01-03-02-01-mozilla-central-firefox-34.0a1.ru.linux-x86_64
wfm: 2014-09-02-03-02-02-mozilla-central-firefox-34.0a1.en-US.linux-x86_64
wfm: 2014-12-17-03-02-02-mozilla-central-firefox-37.0a1.en-US.linux-x86_64
Component: Untriaged → Developer Tools: Profiler
Summary: Profiler frequently stops working → Profiler does not start again. [frequently stops working]
as :Aleksej posted, and tested myself, was able to recreate this on Fx35 Beta (OSX), but in Nightly (Fx37), I was unable to reproduce this.

Can you confirm that this is no longer an issue on Nightly, Liam?
Flags: needinfo?(cosinusoidally)
(Reporter)

Comment 3

4 years ago
This reproduces for me in the current release version of Firefox (35) both on Windows and Linux.

This does not reproduce on Nightly on Linux (38.0a1 (2015-01-23))
Flags: needinfo?(cosinusoidally)
So looks like this is fixed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME

Updated

a month ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.