reproducible lightning 3.6b2 + thunderbird 34.0b1 crash on calendar launch

RESOLVED DUPLICATE of bug 1106034

Status

Calendar
General
--
critical
RESOLVED DUPLICATE of bug 1106034
3 years ago
3 years ago

People

(Reporter: terrygalant, Unassigned)

Tracking

Lightning 3.6
x86_64
Linux

Details

(Reporter)

Description

3 years ago
I have thunderbird 34.0b1 installed on 64-bit linux

I created a new user.

I installed & enabled ONLY the Lightning 3.6b2 extension

Then I launch TBird from the command line it boots OK

	thunderbird

		(process:6804): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed
		[calBackendLoader] Using libical backend at /home/terry/.thunderbird/vqkru77z.new/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/libical.manifest

but as soon as I click to go to the calendar tab, the thunderbird window goes completely black and I see this stack trace in the console

	TypeError: Components.classes[cid] is undefined
	-- Exception object --
	*
	-- Stack Trace --
	_calIcalCreator/<@resource://calendar/modules/calUtils.jsm -> file:///home/terry/.thunderbird/vqkru77z.new/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js:17:13
	jsDateToDateTime@resource://calendar/modules/calUtils.jsm:517:23
	now@chrome://calendar/content/calUtils.js:380:13
	switchToView@chrome://calendar/content/calendar-views.js:310:23
	ltnSwitch2Calendar@chrome://lightning/content/messenger-overlay-sidebar.js:409:5
	calendarTabType.modes.calendar.openTab@chrome://lightning/content/messenger-overlay-sidebar.js:45:13
	openTab@chrome://messenger/content/tabmail.xml:559:1
	oncommand@chrome://messenger/content/messenger.xul:1:1

I can't get to any menus, and can't exit it out of it.  I have to quit the application.
(Reporter)

Updated

3 years ago
Summary: reproductible lightning 3.6b2 + thunderbird 34.0b1 crash on calendar launch → reproducible lightning 3.6b2 + thunderbird 34.0b1 crash on calendar launch

Comment 1

3 years ago
I assume this is the same as Bug 1106034.
(Reporter)

Comment 2

3 years ago
yes, thanks --> https://bugzilla.mozilla.org/show_bug.cgi?id=1106034#c21
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1106034
You need to log in before you can comment on or make changes to this bug.