Update paths for Android Nightly FTP locations

RESOLVED FIXED

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: aaronmt, Assigned: parkouss)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

4 years ago
There are new folder paths for Android Nightly ARMv7 builds based on recent work to split up the APK between Gingerbread and all other versions of Android 

API10 and API9:

(API10 might change to API11, so I'd hold off on this for a week to see if that happens. Due to oversight that API10 is still 2.3)

http://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/latest-mozilla-central-android-api-10/

http://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/latest-mozilla-central-android-api-9/

We might have to consider supplying a '2.3' flag to mozregression to check the appropriate path for a build appropriate for Gingerbread.
Yes, I'd probably fix this by adding a "fennec-2.3" app option (as opposed to fennec) to mozregression. Otherwise I think this is pretty similar to the behaviour we have on desktop, where we choose mozilla-central or trunk for a directory to look into depending on the age of the build we're trying to get.
(Assignee)

Comment 3

4 years ago
If the branch name just vary upon time, there is no need for a fennec-2.3 new app name - we will require it if different branches may be requested for a given date.

I'm thinking that it will be easier to add this once pull request https://github.com/mozilla/mozregression/pull/144 will be merged.
(In reply to Julien Pagès from comment #3)
> If the branch name just vary upon time, there is no need for a fennec-2.3
> new app name - we will require it if different branches may be requested for
> a given date.

That's the tricky thing, it varies both upon time *and* platform. Older builds work fine on all platforms (and you can get them from the same location) but for newer fennec builds you need to get them from different locations depending on whether you're testing for Android 2.3 or 4.0.

> I'm thinking that it will be easier to add this once pull request
> https://github.com/mozilla/mozregression/pull/144 will be merged.

Yes, we should merge that first.
(Reporter)

Comment 5

4 years ago
Did you guys push a new version out with this?
(Assignee)

Comment 6

4 years ago
Not yet - but I can work on this tomorrow probably. If I understand well:

app        path                             date
fennec     mozilla-central-android          
fennec     mozilla-central-android-api-10   >= 2014-12-06
fennec     mozilla-central-android-api-11   >= 2014-12-13
fennec-2.3 mozilla-central-android-api-9    >= 2014-12-06

Is that right ?
(Reporter)

Comment 7

4 years ago
We only care about API9 (2.3) (includes max to API 10)

http://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/latest-mozilla-central-android-api-9/

and of course API11 (3.0+) our main Nightly APK

http://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/latest-mozilla-central-android-api-11/fennec-37.0a1.multi.android-arm.apk

The others are not used anymore (mozilla-central-android, mozilla-central-android-api-10 (was a test)).
(Assignee)

Comment 8

4 years ago
Created attachment 8544669 [details] [review]
Update android nightly paths

I can see here http://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/2014/12/ that there is no mozilla-central-android-api-11 for a few days, so I suppose it is good to have mozilla-central-android-api-10 for these days.

Let's check the logic with William;
Assignee: nobody → j.parkouss
Status: NEW → ASSIGNED
Attachment #8544669 - Flags: review?(wlachance)
Comment on attachment 8544669 [details] [review]
Update android nightly paths

This all looks good to me, I assume you've tested it? I can if you're not able to.

Don't we also have to do the same thing for inbound?
Attachment #8544669 - Flags: review?(wlachance) → review+
(Assignee)

Comment 10

4 years ago
(In reply to William Lachance (:wlach) from comment #9)
> This all looks good to me, I assume you've tested it? I can if you're not
> able to.

I tested it until the download, and checked the printed file name. I suppose it is OK since it is what matters here, but maybe you can try it a bit more.

> Don't we also have to do the same thing for inbound?

Good question, I was thinking about it and forgot to ask. Maybe Aaron can help on this ?
(Assignee)

Comment 12

4 years ago
Hmm I see, thanks.

This may a bit more complicated - I will look at it soon.
(Assignee)

Comment 13

4 years ago
Created attachment 8545162 [details] [review]
Update android nightly and inbound paths

I added two more commits in the pull request.
I fixed inbound by looking into every possible inbound build folder, ie:

fennec: mozilla-central-android, mozilla-central-android-api-10 and mozilla-central-android-api-11

fennec-2.3: mozilla-central-android and mozilla-central-android-api-9

Then sort / filter builds on timestamps as usual.

I tested it quicly:


mozregression -g 2014-12-29 -b 2014-12-30 --app fennec
 0:03.11 LOG: MainThread Bisector INFO Got as far as we can go bisecting nightlies...
 0:03.11 LOG: MainThread Bisector INFO Last good revision: 8850aa0f5332
 0:03.11 LOG: MainThread Bisector INFO First bad revision: 67872ce17918
 0:03.11 LOG: MainThread Bisector INFO Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=8850aa0f5332&tochange=67872ce17918

 0:03.11 LOG: MainThread Bisector INFO ... attempting to bisect inbound builds (starting from previous week, to make sure no inbound revision is missed)
 0:03.71 LOG: MainThread Bisector INFO Getting inbound builds between b915a50bc6be and 67872ce17918
 0:48.51 LOG: MainThread Test Runner INFO Testing inbound build with timestamp 1419376773, revision 5910d49f
 0:48.51 LOG: MainThread Test Runner INFO Downloading build from: http://inbound-archive.pub.build.mozilla.org/pub/mozilla.org/mobile/tinderbox-builds/mozilla-inbound-android-api-11/1419376773/fennec-37.0a1.en-US.android-arm.apk


mozregression -g 2014-12-29 -b 2014-12-30 --app fennec-2.3
 0:03.31 LOG: MainThread Bisector INFO Got as far as we can go bisecting nightlies...
 0:03.31 LOG: MainThread Bisector INFO Last good revision: 8850aa0f5332
 0:03.31 LOG: MainThread Bisector INFO First bad revision: 67872ce17918
 0:03.31 LOG: MainThread Bisector INFO Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=8850aa0f5332&tochange=67872ce17918

 0:03.31 LOG: MainThread Bisector INFO ... attempting to bisect inbound builds (starting from previous week, to make sure no inbound revision is missed)
 0:03.88 LOG: MainThread Bisector INFO Getting inbound builds between b915a50bc6be and 67872ce17918
 0:53.83 LOG: MainThread Test Runner INFO Testing inbound build with timestamp 1419376773, revision 5910d49f
 0:53.83 LOG: MainThread Test Runner INFO Downloading build from: http://inbound-archive.pub.build.mozilla.org/pub/mozilla.org/mobile/tinderbox-builds/mozilla-inbound-android-api-9/1419376773/fennec-37.0a1.en-US.android-arm.apk

Will, maybe you could test more if you like. :)
Attachment #8544669 - Attachment is obsolete: true
Attachment #8545162 - Flags: review?(wlachance)
(Assignee)

Comment 14

4 years ago
Also, this is not directly related but I will probably create a bugzilla entry to refactor some code that download things in threads. We now have some parts of the code that are somewhere redundant.
Comment on attachment 8545162 [details] [review]
Update android nightly and inbound paths

This works great, thanks! merged.
Attachment #8545162 - Flags: review?(wlachance) → review+
Released mozregression 0.31 with the changes as well.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.