[Homescreen] Very difficult to open homescreen/smart collection settings on default/full homescreen layout

RESOLVED DUPLICATE of bug 1103270

Status

Firefox OS
Gaia::Homescreen
RESOLVED DUPLICATE of bug 1103270
4 years ago
4 years ago

People

(Reporter: Jeremiah Lee, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 affected)

Details

(Whiteboard: [2.2-flame-reduced-run], URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8533270 [details]
hssetting_logcat.txt

Description:
With default layout (apps fill all of homescreen area), it is very difficult to long press on Homescreen to open Homescreen/Smart Collection settings screen. Long pressing most areas of homescreen will bring up Edit screen.
   
Repro Steps:
1) Update a Flame device to BuildID: 20141208040202
2) On Homescreen, long press in open areas to attempt to open Homescreen/Smart Collection settings
  
Actual:
With default layout (apps fill all of homescreen area), long pressing most areas of Homescreen will open homescreen edit screen. It is very difficult to open homescreen/smart collection settings when homescreen is full.
  
Expected: 
User is able to open homescreen/smart collection settings when homescreen is full.
  
Environmental Variables:
Device: Flame 2.2 Master (319mb) (Kitkat Base)(Full Flash)
BuildID: 20141208040202
Gaia: 0e429d970c160e580e19e61ad8ff5612de159f00
Gecko: c4c7442e9113
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
  
Notes: User will not be able to get to Smart Collection settings with this issue. 
  
Repro frequency: 100%
See attached: video clip (http://youtu.be/zUsgTACqI8o), logcat (hssetting_logcat.txt)
(Reporter)

Comment 1

4 years ago
Does not occur on Flame 2.0 or Flame 2.1. Different Homescreen design/functionality.

User is able to open homescreen/smart collection settings when homescreen is full. Areas between app groups can be long pressed and will bring up settings (smart collection/homescreen).


Device: Flame 2.1 (319mb) (Kitkat Base)(Full Flash)
BuildID: 20141205001201
Gaia: 38e17b0219cbc50a4ad6f51101898f89e513a552
Gecko: 8b92c4b8f59a
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Flame 2.0 (319mb) (KitKat Base)(Full Flash)
Build ID: 20141208000206
Gaia: 856863962362030174bae4e03d59c3ebbc182473
Gecko: e40fe21e37f1
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 32.0 (2.0)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
(Reporter)

Comment 3

4 years ago
Long pressing a divider does not open context menu.
Test case: https://moztrap.mozilla.org/manage/case/13199/
This appears to be a dupe of bug 1103270
Status: NEW → RESOLVED
Last Resolved: 4 years ago
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
Resolution: --- → DUPLICATE
Duplicate of bug: 1103270
You need to log in before you can comment on or make changes to this bug.