Localize Select Amount Snippet and email text into: DE, FR, ES, PT-BR

RESOLVED FIXED

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: adam, Assigned: alicoding)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [EOYFR2014][snippet] [p1])

(Reporter)

Description

4 years ago
These four localized snippets are currently sending significant traffic to the EOY campaign: DE, FR, ES, PT-BR.

Based on the things we have learned from testing on the EN channel, we could make significant improvements to the fundraising conversion rates for these four locales.

We want to replace the current localized snippets which look like this example:
  https://snippets.mozilla.com/show/4793/

With the 'Select Amount' snippet design which is performing so well for EN, e.g.:
  https://snippets.mozilla.com/show/4758/

We want to localize the existing copy on: https://snippets.mozilla.com/show/4793/ and also the new copy on Bug 1107957 which is not yet live.

-----

= Text from current snippet:

Mozilla, the non-profit behind Firefox, relies on grants and donations from people like you. 

If everyone reading this donates a few dollars, we can be fully funded for another year.

Donate.

= Text from new variant:

Dear Firefox users: Mozilla puts the public good and user privacy before profit. If Firefox is useful to you, take one minute to support the non-profit behind it. 

If everyone reading this donates $3, Mozilla's fundraiser would be over within an hour. Thank you.

Donate.
(Reporter)

Comment 1

4 years ago
@Ali, does this give you enough info?
Flags: needinfo?(ali)
(Assignee)

Comment 2

4 years ago
I'm not sure about one thing here which is the process of getting strings request for Mozilla L10N team to translate since we have to do it that way for snippet.

Andrea do you know the right process here? I remember after our conversation with :flod that we need to do it the other way correct?
Flags: needinfo?(ali) → needinfo?(andrea)
I'm not sure this product/component will actually work since you cannot select the locales in the bug. Perhaps file this on product mozilla.org: L10N? Then you can select locales, which flag the localizers. Also please cc Flod, Fabio, and Michael Kelly. Once filed, email Flod directly with the bug URL, to make sure this process is done properly and we can escalate this translation given the revenue impact.
Flags: needinfo?(andrea)
This component is quite invisible to localizers and me. I'm moving it to Mozilla Localization::Other, use it as a tracker and file individual bugs in Mozilla Localization::Locale.

The request is a bit unclear though. For example "Text from current snippet" is not actually the current snippet, that would be:

> Mozilla, the maker of Firefox, is a non-profit and we rely on donations. 
> If everyone reading this gave $3, we would only have to fundraise 1 day a year. 
> Donate today.

And I can't reach https://snippets.mozilla.com/show/4758/

In the end the request is to localize this text?

> Dear Firefox users: Mozilla puts the public good and user privacy before profit. 
> If Firefox is useful to you, take one minute to support the non-profit behind it. 
> If everyone reading this donates $3, Mozilla's fundraiser would be over within an hour. Thank you.
> Donate.

Are they supposed to localize the 3$ part or not?
Component: Localization → Other
OS: Mac OS X → All
Product: Webmaker → Mozilla Localizations
Hardware: x86 → All
Hi Flod -- the EN snippets have already been changed to a different version late last night based on testing, that's why you can't see https://snippets.mozilla.com/show/4758/ at the moment. We want to update the DE, PT-BR, FR, ES snippets, too, so we are requesting the following 2 variants to be localized (I removed the $3 reference, though the forms are in USD):


**Variant A:

Mozilla, the non-profit behind Firefox, relies on grants and donations from people like you. 

If everyone reading this donates a few dollars, we can be fully funded for another year.

Donate.

**Variant B:

Dear Firefox users: Mozilla puts the public good and user privacy before profit. If Firefox is useful to you, take one minute to support the non-profit behind it. 

If everyone reading this donates a few dollars, Mozilla's fundraiser would be over within an hour. Thank you.

Donate.

====
By localizing 2 variants now, we can have both ready to implement during the course of the campaign. 

Each locale will see the corresponding form after they click (the amount they select will carry over to the form):

FR:
https://sendto.mozilla.org/page/contribute/givenow-seq-fr

PT-BR:
https://sendto.mozilla.org/page/contribute/givenow-seq-pt-br

DE:
https://sendto.mozilla.org/page/contribute/givenow-seq-de

ES:
https://sendto.mozilla.org/page/contribute/givenow-seq-es
Depends on: 1109468
Depends on: 1109469
Depends on: 1109470
Depends on: 1109471
(Assignee)

Comment 6

4 years ago
So it seems to me that this ticket is now a meta bug to get all translation for all of the requested languages.

I think this next part after all translation completed is to put them up on snippet page which I don't have the right to do so, but I'm happy to help if I can get access to that? But I don't know who is the right person to talk to after this.

:adamlofting or :flod do you know what is the right procedure after this one?
Flags: needinfo?(francesco.lodolo)
Flags: needinfo?(adam)
frios is already CCed to all bugs, and he's managing snippets. And I think also mkelly can help if needed.
Flags: needinfo?(francesco.lodolo)
(Assignee)

Updated

4 years ago
Flags: needinfo?(adam)

Comment 8

4 years ago
Hey all, sorry to jumping in until now. I submit specific requests for translating content on snippet. It's all submitted at the same time each month. 

@Flod, I'll include this request in the bug unless you've already done something with it? 

Unfortunately this one would need to be translated much sooner since it's running in December. Do you think this is possible?

@Andrea, we typically give l10n more notice, so this would be an exception if possible.
Flags: needinfo?(francesco.lodolo)

Comment 9

4 years ago
Wasn't completely caught up. Looks like ball is rolling. I'll get them set up in snippet. Thanks.
Flags: needinfo?(francesco.lodolo)
Thanks Fabio, I talked with flod at the workweek about our EOY translation process. It could be better, but EOY is a very unique challenge in regards to translation. Our testing is iterative and we often learn new language works better in the midst of the campaign, so it is not always possible to give L10N as much notice as they are used to / we would like. This is one of those cases -- this snippet performed 2x our original snippet, and we're seeing higher than expected traffic from these locales. Wo we need to translate now and quickly. We tried using Transifex to save L10N the pain of this type of "rush" but the quality was not optimum. 

Flod has agreed to help us get speedy translations when possible during the rest of the campaign, given the many $100s thousands of dollars at stake.

But yes I want to improve this process in the future -- at least as much of the translation needs as we can anticipate.
Blocks: 1109853
We have de and fr confirmed, pt-BR (not sure if someone needs to check), still waiting for es-ES.
Using this bug to track also email localization.

Fabio, we should have all 4 locales for snippets. Can you close those bugs when they're in the system?
Summary: Localize Select Amount Snippet into: DE, FR, ES, PT-BR → Localize Select Amount Snippet and email text into: DE, FR, ES, PT-BR
(Assignee)

Comment 13

4 years ago
Hi :frios,

I'm wondering how can we check or can we get status update on any of the completed snippet with new translated one?

Thanks!
Flags: needinfo?(frios)

Comment 14

4 years ago
Hey all snippets have been set up and pushed out. Thank you. I'll close out the individual bugs.

https://snippets.mozilla.com/show/4826/
https://snippets.mozilla.com/show/4829/
https://snippets.mozilla.com/show/4828/
https://snippets.mozilla.com/show/4827/
Flags: needinfo?(frios)
As I commented in the French bug I completely missed the fact that "Donate" was a button: I didn't realize this was the interactive snippet (remember the broken url?), so I didn't explain that in the request. 

In these cases it's *fundamental* to explain from the start if a string has a different role, and if there are length limitations. I'm going to ping Marcelo from pt-BR to make sure that the button looks right.
(Assignee)

Updated

4 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.