Inconsistent way of moving non-eWindowType_child windows

REOPENED
Unassigned

Status

()

defect
--
major
REOPENED
20 years ago
10 years ago

People

(Reporter: pavlov, Unassigned)

Tracking

Trunk
Future
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Currently things such as gfx combo boxes, when they pop up windows are calling
move with x and y coords relative to their parents.  Other things, such as xul
popups call move based on screen coords.  The only way to tell the different in
which way to move these is to see if one has a parent or not.  Xul popups should
soon have parents which will cause move to be broken.  We need to have gfx
widgets position any new non-eWindowType_child windows with global coords which
they can obtain by calling WidgetToSceen.
Assignee: kmcclusk → rods
Rod, reassigning to you.

Repositioning the combo dropdown using absolute coordinates is straight forward.
But, there may be issues with the view system having a view that is positioned
with absolute coordinates.
I wasn't sure what to do in the mean time for Photon so I just Move the
Pop-Up offset from the current cursor position, since I don't have a
parent to offset from.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → INVALID
Currently, the view system and the positioning of widgets are all relative to
their parents. It has not been a requirement that we support absolutely
positioned widgets. There are several approaches that can be used for pops ups
that would not impact the view system or require other changes. If this
resolution is unsatisfactory, call a meeting with Kevin, Patrick, myself, and
Hyatt. This is not a bug, it is a feature request that needs an indepth
discussion.
Status: RESOLVED → REOPENED
this is a bug.  there are two different groups doing two different things which
will cause major confusing.  We should probably have a meeting to discuss this.
Does anyone have a particular time when would be good?
Rod, remember that all feature requests to your group are now bugs. ;) what _is_
a girl to do?
Request or defect, it is still valid. clearing resolution.
Resolution: INVALID → ---
Status: REOPENED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → LATER
changing to later
Updating QA contact.
QA Contact: phillip → bsharma
reopening and marking Future...
Status: RESOLVED → REOPENED
Resolution: LATER → ---
Target Milestone: --- → Future
QA Contact Update
QA Contact: bsharma → vladimire
Priority: P3 → --
QA Contact: vladimire → tpreston
Assignee: rods → nobody
QA Contact: tpreston → layout.form-controls
You need to log in before you can comment on or make changes to this bug.