Lazy SWF parsing breaks async file loading

RESOLVED FIXED

Status

Firefox Graveyard
Shumway
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: yury, Assigned: till)

Tracking

({regression})

33 Branch
regression
Dependency tree / graph

Details

(Reporter)

Description

3 years ago
The async loading is used in the extension (I added simulation of that in pull request #1919, see fileReadChunkSize).

STR:
1. Open inspector at http://localhost:8000/examples/inspector/inspector.html?rfile=../racing/race3.swf
2. Set fileReadChunkSize to 10000, and refresh

Expected result:

racing game works

Actual result:

game execution breaks -- the execution started without the root (= null) at https://github.com/mozilla/shumway/blob/master/src/player/player.ts#L186
(Assignee)

Comment 1

3 years ago
Will look into it tomorrow.
Assignee: nobody → till
Status: NEW → ASSIGNED
OS: Mac OS X → All
Hardware: x86 → All
(Reporter)

Comment 2

3 years ago
4b42e06f6e7ebb210ae814acc85b3b0ebf174dc1 is the first bad commit
commit 4b42e06f6e7ebb210ae814acc85b3b0ebf174dc1
Author: Till Schneidereit <till@tillschneidereit.net>
Date:   Fri Oct 24 14:29:14 2014 -0700
Keywords: regression
Blocks: 1110298
Blocks: 1118980
(Assignee)

Comment 3

3 years ago
This has since been fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
No longer blocks: 1110298
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.