Bugs due to update of android studio from 0.9 to 1.0.0

RESOLVED DUPLICATE of bug 1098239

Status

()

RESOLVED DUPLICATE of bug 1098239
4 years ago
4 years ago

People

(Reporter: imjalpreet, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20141206004001

Steps to reproduce:

After updating from Android Studio 0.9 to Android Studio 1.0.0, when we try to import the gradle project to IJ/AS, we will get a few errors.


Actual results:

The errors are: 
[1] Gradle DSL method not found: 'runProguard()'. In the latest version of the gradle, it no longer supports runProguard, we need to change it to minifyEnabled. This change has to be done in the build.gradle.

[2] ApplicationId in Library Projects: Now we cannot use applicationId to customize the package of a library project. The package name has to be fixed in library projects (and specified as packageName/applicationId in the manifest).

These are the two changes that I have found till now.
(Reporter)

Updated

4 years ago
OS: Linux → All
Hardware: x86_64 → All
Created attachment 8533452 [details]
Correction for Bug [1]
Created attachment 8533453 [details]
Correction for Bug [2]
Thanks for reporting these.  Can you tell me what Gradle version AS is using (2.1?) and which Android-Gradle plugin AS is using (0.13.0?)?  We had problems with bumping versions before: Bug 1098239.
Status: UNCONFIRMED → NEW
Ever confirmed: true
The 2.2.1 is used by AS 1.0.0-rc4 and AS 0.8.+ or 0.9 uses 1.11 or 1.12.
(Reporter)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1098239
You need to log in before you can comment on or make changes to this bug.