Closed Bug 1108920 Opened 5 years ago Closed 4 years ago

Network > Clear Now button clear cache but doesn't reset the label indicating the cache size

Categories

(Firefox :: Preferences, defect)

34 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1066970
Tracking Status
firefox37 --- affected

People

(Reporter: j.l.madushan, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0
Build ID: 20141125180439

Steps to reproduce:

Clicked Settings > Network > Clear now ones .


Actual results:

Cache wiped but the label indicating the cache size stayed the same. If clear now is clicked again it resets to zero.


Expected results:

Label should reset to zero on the first click too.
Build identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0

Steps to reproduce:

tools->options->Advanced->Network->Clear Now(Pressed 1 time)

Actual Results:

Nothing happened to the value of the cached size at the first time press.But when clicks it for the second time,value got changed to another value.That value was smaller than the previous value.Then for the third time press,the value got zero.

Expected results:

The value of the cached label should be changed to zero at the first time click,not at the second or third time clicks.
Component: Untriaged → Preferences
I can confirm this issue on the latest Nightly 37.0a1 (buildID: 20150107030217) on Windows 7 64bit and Mac OSX 10.9.5: the value of the cached label is changed to zero at the second time clicks.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 7 → All
Hardware: x86_64 → All
status-firefox38: --- → affected
status-firefox39: --- → affected
status-firefox40: --- → affected
status-firefox41: --- → affected
status-firefox42: --- → affected
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1066970
Seeing this in 44.0.2 stable, on Linux and Windows platforms. Most of the time the "Clear Now" button has to be pressed a second time for the cache size to be reported as 0 . Sometimes pressing Clear Now once will reduce the size number reported but will not actually cause it to display 0 until a second time pressing the button.
You need to log in before you can comment on or make changes to this bug.