[Loop] Can't open only audio call from received shared link.

RESOLVED FIXED in mozilla37

Status

Hello (Loop)
Client
--
major
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Javier de Prado, Assigned: Carmen Jimenez Cabezas)

Tracking

(Blocks: 1 bug)

unspecified
mozilla37
x86
Gonk (Firefox OS)
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [mobile app][regression-1.1])

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

3 years ago
ENV:
v1.1, v 4212078
FireE comercial build.

STR:
1.- Open received shared link (vía sms or email) on FireE.
2.- Once browser is opened, select "Voice conversation" option.

ACTUAL RESULT: Loop app is opened, and outgoing Video conversation is established.

EXPECTED RESULT: outgoing audio conversation should be established.
I am missing some steps... why should we start an audio conversation call?
Flags: needinfo?(javier.deprado)
(Reporter)

Comment 2

3 years ago
From Browser you can open video call by default (green button, with text "start" and cam icon), or clicking on the small arrow pointing down, you can choose "Voice conversation" option.
Even having audio call by default in loop app settings, video call is opened from the mobile browser.
Flags: needinfo?(javier.deprado)
After checking that sharing an URL between two desktops, when browser is opened and "Voice conversation" is selected, is working fine and an outgoing audio conversation is launched we suspect that the fault is in the Loop  mobile client.

It seems that we are not checking the callType value in the LOOP_CALL activity sent from the Standalone UI, and that's the reason we are not setting correctly this variable.

Apart from that, and after including some logs, we are seeing that the callType sent from the Standalone UI is "undefined" so we are not sure if the Standalone UI is working as expected either, Carmen could you be so kind of checking this? and please, let's know if we need to open a standalone bug if it's necessary, thanks a lot!
Flags: needinfo?(carmen.jimenezcabezas)
(Assignee)

Updated

3 years ago
Assignee: nobody → carmen.jimenezcabezas
Flags: needinfo?(carmen.jimenezcabezas)
(Assignee)

Comment 4

3 years ago
Created attachment 8535796 [details] [diff] [review]
V1  proposed patch
Attachment #8535796 - Flags: review?(standard8)
(Assignee)

Updated

3 years ago
Component: Gaia::Loop → Client
Product: Firefox OS → Loop
QA Contact: anthony.s.hughes
Comment on attachment 8535796 [details] [diff] [review]
V1  proposed patch

Review of attachment 8535796 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/components/loop/standalone/content/js/webapp.jsx
@@ +153,5 @@
>  
>    var FxOSConversationModel = Backbone.Model.extend({
> +    setupOutgoingCall: function(selectedCallType) {
> +      if (selectedCallType) {
> +       this.set("selectedCallType", selectedCallType);

nit: two-space indent please, although I think you could simplify this not to save the selectedCallType, unless there's a specific reason that the FxOSConversationModel needs it.
Attachment #8535796 - Flags: review?(standard8) → review+
(Assignee)

Comment 6

3 years ago
Created attachment 8537133 [details] [diff] [review]
V2  proposed patch

r = standard8
Attachment #8535796 - Attachment is obsolete: true
Attachment #8537133 - Flags: review+
(Assignee)

Comment 7

3 years ago
(In reply to Mark Banner (:standard8) from comment #5)

> nit: two-space indent please, although I think you could simplify this not
> to save the selectedCallType, unless there's a specific reason that the
> FxOSConversationModel needs it.

 I need to save the state because when the app it's not installed this will be called twice (one directly and one after the app is installed). On the second call we don't have that available anymore, and so it's recovered from the object state.
(Assignee)

Updated

3 years ago
Keywords: checkin-needed
Attachment #8537133 - Attachment is patch: true
Is there a Try link for this? :)
Keywords: checkin-needed
(Assignee)

Comment 9

3 years ago
Sorry!, try:
https://tbpl.mozilla.org/?tree=Try&rev=0674448d2e9f
(Assignee)

Updated

3 years ago
Blocks: 1097703
backlog: --- → Fx35?
Please, we need it for Fx35
This is standalone -- so it just needs to land and merge in m-c this week (which is officially the Fx37 cycle), and it will be in the next release of the standalone app.  We are planning to do another standalone release before Fx35 goes to release (Jan 13).  How soon do you need the standalone updated?
backlog: Fx35? → Fx37+
Flags: needinfo?(oteo)
Can you confirm it will be in the Standalone UI Dev Client as soon as it's merged in m-c?

Obviously, we would like to test it in production as soon as we can, if it's not possible to do it before the end-of-year at, least it would be great to have it by 7th January.
Flags: needinfo?(mreavy)
(Assignee)

Comment 13

3 years ago
treeherder looks ok
https://treeherder.mozilla.org/#/jobs?repo=try&revision=0674448d2e9f
Requesting checkin
Keywords: checkin-needed
(In reply to Maria Angeles Oteo (:oteo) from comment #12)
> Can you confirm it will be in the Standalone UI Dev Client as soon as it's
> merged in m-c?

You can test it on the dev server basically as soon as the code merges to m-c.  You'll know when that happens if you hang out in #loop.  (The system posts to #loop when the standalone code on the dev server is updated.)  

> Obviously, we would like to test it in production as soon as we can, if it's
> not possible to do it before the end-of-year at, least it would be great to
> have it by 7th January.

Let me talk with Mark (Standard8) and the server folks to see if we can update the standalone product on Jan 6.  Standalone updates can roll out in less than a day.  (The last one took only 2-3 hours.)  Doing a needinfo to Mark so this request (to roll out a new standalone on or before Jan 7) is on his radar and so I don't forget to discuss this with him today.
Flags: needinfo?(mreavy) → needinfo?(standard8)
https://hg.mozilla.org/integration/fx-team/rev/353443a10c4b
Flags: in-testsuite+
Keywords: checkin-needed
Whiteboard: [mobile app][regression-1.1] → [mobile app][regression-1.1][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/353443a10c4b
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Whiteboard: [mobile app][regression-1.1][fixed-in-fx-team] → [mobile app][regression-1.1]
Target Milestone: --- → mozilla37
Thanks a lot Maire!
Flags: needinfo?(oteo)
This has landed, and we're planning to push a new standalone app on or before Jan 7.  So I'm clearing the needinfo to Mark.
Flags: needinfo?(standard8)

Updated

3 years ago
Iteration: --- → 37.1
You need to log in before you can comment on or make changes to this bug.