Closed Bug 1109039 Opened 5 years ago Closed 4 years ago

Intermittent browser_bug400731.js | Test timed out - expected PASS

Categories

(Toolkit :: Safe Browsing, defect)

x86
Windows 8
defect
Not set

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox35 --- unaffected
firefox36 --- unaffected
firefox37 --- wontfix
firefox38 --- wontfix
firefox38.0.5 --- wontfix
firefox39 --- affected
firefox40 --- affected
firefox-esr31 --- unaffected
firefox-esr38 --- affected

People

(Reporter: cbook, Unassigned)

References

()

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

Windows 8 64-bit mozilla-inbound pgo test mochitest-browser-chrome-1

https://treeherder.mozilla.org/logviewer.html#?job_id=4453241&repo=mozilla-inbound

23:06:32 INFO - 1485 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/safebrowsing/content/test/browser_bug400731.js | Test timed out - expected PASS
Assignee: nobody → mmc
Status: NEW → ASSIGNED
Comment on attachment 8545279 [details] [diff] [review]
Disable browser_bug400731.js on windows (

Review of attachment 8545279 [details] [diff] [review]:
-----------------------------------------------------------------

Bug 1100024 seems to make this test flakier on windows only (see failures from Jan when part of that bug was checked in, https://treeherder.mozilla.org/ui/#/jobs?repo=try&revision=8acec4afd6f8, and https://bugzilla.mozilla.org/show_bug.cgi?id=1100024#c41). It's passing on other platforms.
Attachment #8545279 - Flags: review?(gpascutto)
Can't we just investigate why this is flaky instead?
Hey gcp,

I spent some time on this and could not reproduce locally. Merge day is coming up and I'd like to get https://bugzilla.mozilla.org/show_bug.cgi?id=1100024 in. Can we continue investigating after that? I will file a bug to re-enable this test on windows if so.

Monica
Attachment #8545279 - Flags: review?(gpascutto) → review+
https://hg.mozilla.org/mozilla-central/rev/bfab295de632
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla37
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Sid, can you please help find an owner for this?
Flags: needinfo?(sstamm)
Target Milestone: mozilla37 → ---
Assignee: mmc.bugzilla → nobody
gcp: this is safebrowsing related... you know more about it than I do, any idea who can help us track this down?  Maybe Francois?
Flags: needinfo?(sstamm) → needinfo?(gpascutto)
Francois can own it, with help from me if needed. This probably needs digging into old code and tests more than actual SafeBrowsing knowledge :-)
Assignee: nobody → francois
Flags: needinfo?(gpascutto)
Assignee: francois → nobody
This test hasn't caused problems in the past 8 months, closing.
Status: REOPENED → RESOLVED
Closed: 5 years ago4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.