Hebrew in "Subject" appears as question marks if there's no Hebrew in the message body

RESOLVED INVALID

Status

Thunderbird
Untriaged
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: Pesach, Unassigned)

Tracking

31 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 20141113143407

Steps to reproduce:

Example: I send a message wherein at least some of the subject letters are Hebrew AND there are no Hebrew letters in the body (may contain Russian, English, some URL links instead).E.g., emailing link to the webpage http://www.hamshushalayim.co.il/place/%D7%9E%D7%95%D7%96%D7%99%D7%90%D7%95%D7%9F-%D7%99%D7%94%D7%93%D7%95%D7%AA-%D7%90%D7%99%D7%98%D7%9C%D7%99%D7%94/ 


Actual results:

All Hebrew letters in the subject are replaced with question marks. A subject like "מוזיאון יהדות איטליה | Hamshush" becomes "??????? ????? ?????? | Hamshush" both in the "Sent" folder copy and in the message that reaches a recipient.

*I have not changed my add-on list and TB setting for quite a while, so I believe this behavior was introduced by one of the recent TB updates. My OS is Windows 7 Home Premium, 64 bit.

*Running TB in a safe mode does not solve the problem. 

*Adding at least one Hebrew letter to the message body seems to be a workaround.
(Reporter)

Comment 1

3 years ago
Sorry for the trouble, I think I've identified the problem. For historical reasons (maybe a decade ago) TB was set to use KOI-8 for incoming and outgoing messages. Interestingly, this caused no problems until now. 
Resetting to UTF-8 seems to solve the aforementioned issue with Hebrew and hopefully will not affect my archival messages in Russian.

Please feel free to delete the report if it is of little value for others.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.