Date search broken for an italian localization error

RESOLVED FIXED

Status

Mozilla Localizations
it / Italian
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: Marco Gaiarin, Assigned: Roberto Principiano)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
If i go to Edit -> Find -> Search Messages and i chiise a filter on 'Date', the date are printed as '09122014' and the filter does not work, i mean:
 + if i choose to filter on 'is', no message match,
 + if i choose to filter on 'not is' all messages match
 + if i choose to filter on 'is before', no message match
 + if i choose to filter on 'is after', all messages match

note that this bug is a localization bug, and apply to ALL TB 31.X version, at least till current 31.3, on every architecture (at least on Windows and Linux).

Looking at italian forum (in italian):
 http://forum.mozillaitalia.org/index.php?topic=61987.0
bug seems know and a workaround is present, eg to use:
 defaultPref("mailnews.search_date_separator", "/");

I hope will be fixed soon. Thanks.
I'm reading klades' answer and everything seems already correct on the localization side
http://hg.mozilla.org/releases/l10n/mozilla-release/it/file/default/mail/chrome/messenger/messenger.properties#l167

Unfortunately the problem is with the ESR cycle, 34.0 beta1 should be fine :-\
http://hg.mozilla.org/releases/l10n/mozilla-release/it/file/047dd4e595ad/mail/chrome/messenger/messenger.properties#l169
Assignee: nobody → l10n-it
Status: UNCONFIRMED → NEW
Component: Search → it / Italian
Ever confirmed: true
OS: Linux → All
Product: Thunderbird → Mozilla Localizations
QA Contact: francesco.lodolo
Hardware: x86_64 → All
Version: 31 → unspecified
Assignee: l10n-it → roberto.principiano
Fixed as far as I can tell.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
(Reporter)

Comment 3

2 years ago
Sorry, totally forgotten to have fired that bug. ;-)

I've briefly tested TB 38 on Linux, and i confirm bug get fixed.

I will test TB 38 and 35 shortly... if there's some culprit i'll write here. Thanks.
You need to log in before you can comment on or make changes to this bug.