Talk bubbles should be aligned based on UX doc

RESOLVED FIXED

Status

support.mozilla.org
BuddyUp
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: espressive, Assigned: espressive)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: p=1 s=bu.2015.1)

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
Currently bubbles are displayed aligned left always. This needs to change based on UX doc also, helpee's will not have avatars.

https://mozilla.app.box.com/s/iuv22j4jo3iwrkgr3srt

Updated

3 years ago
Whiteboard: p=1

Updated

3 years ago
Blocks: 1109642
(Assignee)

Updated

3 years ago
Status: NEW → ASSIGNED

Updated

3 years ago
Whiteboard: p=1 → p=1 s=bu.2014.4
(Assignee)

Comment 1

3 years ago
Created attachment 8543879 [details] [review]
https://github.com/mozilla/buddyup/pull/47
Attachment #8543879 - Flags: review?(anthony)
Comment on attachment 8543879 [details] [review]
https://github.com/mozilla/buddyup/pull/47

In submit_comment(), we also need to add the 'class="helper-comment' to the <li> we generate.

Otherwise, this is good.
Attachment #8543879 - Flags: review?(anthony)

Updated

3 years ago
Blocks: 1117187

Updated

3 years ago
Whiteboard: p=1 s=bu.2014.4 → p=1 s=bu.2015.1
(Assignee)

Comment 3

3 years ago
I looked at the code and there are a couple of things I need to take care of in order to finish it up.

Currently the class on the list item is set it thread.html and when a user makes a comment, that is not touched, only comment.html is so, I need to amend thread.html or get rid of it and use another approach.

Secondly, I do not have access to the question object, but I do the id, so I need to get the question in order to know whether the new comment is from a helper or, from the original author of the question i.e. the helpee

I will work on this tomorrow, or at the latest Monday.

Anthony, if you have another idea on how this can be resolved, let me know.
Flags: needinfo?(anthony)
I went ahead and fixed this. I've rebased the commit on master too. We can refactor in another bug maybe but I wanted to close this.

https://github.com/mozilla/buddyup/commit/9a4311e8e61ec96643dbc29af1ff472f96338524
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(anthony)
Resolution: --- → FIXED

Updated

3 years ago
Duplicate of this bug: 1117187
You need to log in before you can comment on or make changes to this bug.