CTRL-F4 should close current tab (while in address-bar)

VERIFIED DUPLICATE of bug 102831

Status

SeaMonkey
Tabbed Browser
VERIFIED DUPLICATE of bug 102831
17 years ago
10 years ago

People

(Reporter: Gili Tzabari, Assigned: David Hyatt)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:0.9.6+) Gecko/20011119
BuildID:    2001111911

I should be able to hit CTRL-T (new MDI tab), CTRL-F4 (close current tab)

The problem is that while CTRL-F4 works when the cursor is inside the tab, it
doesn't work if the cursor is locate on the URL-input-field

Reproducible: Always
Steps to Reproduce:
1. CTRL-T
2. CTRL-F4
3.

Actual Results:  Nothing happens

Expected Results:  Tab should close

Comment 1

17 years ago
Use Ctrl+W.  I'm surprised we support Ctrl+F4 at all, actually.  That's an old
MDI shortcut.  Tabs are more SDI.
tabbed browser
Assignee: mpt → hyatt
Component: User Interface Design → Tabbed Browser
QA Contact: zach → blakeross
(Reporter)

Comment 3

17 years ago
Sorry, I'm used to the Netbeans MDI architecture; one which is shared by all
Java applications worldwide (quite a lot!) which uses CTRL-F4 for closing MDI
frames. Can you please add support for CTRL-F4 as a good-will gesture to those
users who use it? ;)

Comment 4

17 years ago
Not OS/2 specific
OS: OS/2 → All

Comment 5

17 years ago

*** This bug has been marked as a duplicate of 102831 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 6

17 years ago
vrfy dupe
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.