Description for changing languages should say "You must restart Mozilla"

VERIFIED FIXED in mozilla0.9.7

Status

SeaMonkey
Preferences
P5
trivial
VERIFIED FIXED
16 years ago
13 years ago

People

(Reporter: Andy Lyttle, Assigned: Samir Gehani)

Tracking

Trunk
mozilla0.9.7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:0.9.5+) Gecko/20011116
BuildID:    2001111608

The description for selecting your language says "You must restart for a new
language setting to take effect."  It should say "You must restart Mozilla for a
new language setting to take effect."

Reproducible: Always
Steps to Reproduce:
1. open Preferences
2. select Appearance
3. read the text

Actual Results:  User is deluded into thinking the computer must be rebooted,
since that's what "you must restart" usually means in other applications.

This is basically the same as Bug 109477.

I found the string here:
http://lxr.mozilla.org/seamonkey/source/xpfe/components/prefwindow/resources/locale/en-US/pref-appearance.dtd#34

Just change it to:
<!ENTITY languageList.txt.label "Choose a language for &brandShortName;. The
setting affects the language for text that appears in dialog boxes, menus,
toolbars, and button labels. You must restart &brandShortName; for a new
language setting to take effect.">

Unfortunately I am too lazy to learn how to make patches.  Of course the change
needs to be localized too...
(Assignee)

Updated

16 years ago
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Priority: -- → P5
Target Milestone: --- → mozilla0.9.7
(Assignee)

Comment 1

16 years ago
Created attachment 58479 [details] [diff] [review]
Add brandShortName.
(Assignee)

Comment 2

16 years ago
morse, please r.
alecf, please rs.
Keywords: patch, review

Comment 3

16 years ago
Comment on attachment 58479 [details] [diff] [review]
Add brandShortName.

r=morse

Updated

16 years ago
Attachment #58479 - Flags: review+

Updated

16 years ago
Attachment #58479 - Flags: superreview+
(Assignee)

Comment 4

16 years ago
Checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Keywords: review
Resolution: --- → FIXED
vrfy'd fixed using 2001.11.28.0x-comm bits on linux rh7.2, mac 10.1.1 and winnt.

also checked that the mozilla bits [at least a linux one from 11/26] say
'Mozilla' instead of 'Netscape 6'.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.