When viewing a question, we should let people load more comments

VERIFIED FIXED in 2015Q2

Status

support.mozilla.org
BuddyUp
VERIFIED FIXED
3 years ago
2 years ago

People

(Reporter: rik, Assigned: rik)

Tracking

unspecified
2015Q2

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: p=3)

Attachments

(2 attachments)

(Assignee)

Description

3 years ago
Currently, we only display the last 20 comments. We should let people load older comments.
(Assignee)

Updated

3 years ago
Blocks: 1061592
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1107997
(Assignee)

Comment 2

3 years ago
This is not a duplicate. bug 1107997 is about loading more questions when displaying a list of questions. This is about loading more comments inside a question.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Updated

3 years ago
Whiteboard: p=1

Updated

3 years ago
Whiteboard: p=1 → p=1 [blocker]

Updated

3 years ago
Whiteboard: p=1 [blocker] → p= [blocker] [ux-needed]
UX for this was provided. Anthony would you mind estimating this?
Flags: needinfo?(anthony)

Updated

3 years ago
Whiteboard: p= [blocker] [ux-needed] → p= [blocker]
We actually said this wasn't a blocker.
Whiteboard: p= [blocker] → p=
Target Milestone: --- → 2015Q2
(Assignee)

Comment 5

3 years ago
Given that it is not a blocker, I'm not going to spend time estimating this yet. Let's do this after the release.
Flags: needinfo?(anthony)

Updated

3 years ago
Whiteboard: p= → p=3
(Assignee)

Comment 6

3 years ago
Created attachment 8623750 [details] [review]
https://github.com/mozilla/buddyup/pull/165

Marcia: Could someone test this branch?
Assignee: nobody → anthony
Status: REOPENED → ASSIGNED
Flags: needinfo?(mozillamarcia.knous)
Attachment #8623750 - Flags: review?(rdalal)
Comment on attachment 8623750 [details] [review]
https://github.com/mozilla/buddyup/pull/165

one small nit. but looks good. r+
Attachment #8623750 - Flags: review?(rdalal) → review+
Created attachment 8624460 [details]
2015-06-18-13-15-56.png

I tested this a bit with the pull request.

A few comments:

(1) Is the load more button intended to be in the middle/top part of the page? I think in the other screens in BuddyUp it is positioned at the bottom.

(2) In my testing, it seems that the comments all showed even with the Load More button. See the testing thread on staging called "This is a long question again" which has more than 25 entries.
Flags: needinfo?(mozillamarcia.knous) → needinfo?(anthony)
(Assignee)

Comment 9

2 years ago
https://github.com/mozilla/buddyup/commit/a871b77fc36ceeec1ab19fce7c11acdee8db6da3

About 1), I decided to put it there because I felt it made more sense to the way you read a thread. You want the latest comments visible first and then you might want more context and load previous comments.

About 2), I've checked both threads and they do not display all the comments. The way we display a thread with n comments is this:

Question
Load More
Comment n-20
…
Comment n

When you press load more, we display this:
Questions
Load More
Comment n-40
…
Comment n-21
Comment n-20
…
Comment n

I'm going to go with this and we can always change it later if it's confusing.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago3 years ago
Flags: needinfo?(anthony)
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.