All users were logged out of Bugzilla on October 13th, 2018

login autocomplete and other things stop working after update to ff 34

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: dutchkind, Unassigned)

Tracking

34 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:34.0) Gecko/20100101 Firefox/34.0
Build ID: 2014112600

Steps to reproduce:

I updated 3 computers running Opensuse Linux to the latest Firefox 34.05 from 33, and since this are multi user systems it envolved several FF profiles.


Actual results:

After the upgrade the autocomplete of passwords stopped working, no password nor username showed up in the correct fields. I also noticed, as symptom, that the url bar did not get the focus when starting FF.
One profile I reinitialized, and this fixed the issues, but since this involved a lot of work I started digging. Resetting FF to the default start page, and then reinitializing some keys releted to tabs in about:config and sometimes repeating the latter made FF start correct again showing a page error like when it was closed incorrectly previously.


Expected results:

The normal FF startup page should be shown and passwords should be autocompleted.
(Reporter)

Updated

4 years ago
Severity: normal → major

Updated

4 years ago
Component: Untriaged → DOM: Core & HTML
Product: Firefox → Core

Comment 1

4 years ago
Did you find out under what circumstances the profiles misbehaved, ie what was causing this behaviour? Because if now you've changed enough to keep things working again, there isn't really any information left for us to use to figure out what the problem was initially...
Severity: major → normal
Component: DOM: Core & HTML → Untriaged
Flags: needinfo?(dutchkind)
Product: Core → Firefox
(Reporter)

Comment 2

4 years ago
I don't know what caused it, but I have backups of profiles from before so I should be able to reproduce the issue but I don't know how to find out what is really the cause. Any suggestions on how to debug this?
Flags: needinfo?(dutchkind)

Comment 3

4 years ago
(In reply to Dutch Kind from comment #2)
> I don't know what caused it, but I have backups of profiles from before so I
> should be able to reproduce the issue but I don't know how to find out what
> is really the cause. Any suggestions on how to debug this?

Are/were you using any add-ons in those profiles? Does disabling/removing them not fix the issue?

If not, on what forms are you seeing failures? All forms? If not, is it forms with just passwords, or also usernames? Do you have multiple usernames stored for those sites? Can you link to some example login forms that fail?

We can go from those questions and see if there are issues with the files in the profile and/or on startup for some reason.
Flags: needinfo?(dutchkind)
(Reporter)

Comment 4

4 years ago
(In reply to :Gijs Kruitbosch from comment #3)
> (In reply to Dutch Kind from comment #2)
> > I don't know what caused it, but I have backups of profiles from before so I
> > should be able to reproduce the issue but I don't know how to find out what
> > is really the cause. Any suggestions on how to debug this?
> 
> Are/were you using any add-ons in those profiles? Does disabling/removing
> them not fix the issue?

I tried by starting in safe-mode, no difference. Then I just removed all addons, also no difference

> If not, on what forms are you seeing failures? All forms? If not, is it
> forms with just passwords, or also usernames? Do you have multiple usernames
> stored for those sites? Can you link to some example login forms that fail?

Any site with passwords, sites where I have multiple passwords and site where I have just one. It happens with forms with username and password combi's i.e. on this site bugzilla.mozilla.org
Flags: needinfo?(dutchkind)
(Reporter)

Comment 5

4 years ago
I have finally discovered where the problem is. I saw that when I delete prefs.js, the problem was gone so I have been removing lines manually from prefs.js until the problem was solved. Appears that when I remove user_pref("browser.startup.homepage", "http://download.opensuse.org/repositories/");
the problems is solved. Restoring this line gives the problem. Any idea why this goes wrong? I guess I have had this line in my profile for quite some time and suddenly it gives a problem.

Comment 6

4 years ago
(In reply to Dutch Kind from comment #5)
> I have finally discovered where the problem is. I saw that when I delete
> prefs.js, the problem was gone so I have been removing lines manually from
> prefs.js until the problem was solved. Appears that when I remove
> user_pref("browser.startup.homepage",
> "http://download.opensuse.org/repositories/");
> the problems is solved. Restoring this line gives the problem. Any idea why
> this goes wrong? I guess I have had this line in my profile for quite some
> time and suddenly it gives a problem.

I don't know how that could in any way be relating to password/autocomplete issues.

If you create a new profile, verify that username/password autocomplete works, and then add that line to prefs.js, does that break it in the new profile?

Comment 7

4 years ago
This bug is a duplicate of https://bugzilla.mozilla.org/show_bug.cgi?id=1120236. I just verified that restoring the default search bar does indeed fix the problem.

Comment 8

4 years ago
(In reply to Ajay Gupta from comment #7)
> This bug is a duplicate of
> https://bugzilla.mozilla.org/show_bug.cgi?id=1120236. I just verified that
> restoring the default search bar does indeed fix the problem.

That bug doesn't affect 34, so that doesn't make a lot of sense...

Comment 9

4 years ago
(In reply to :Gijs Kruitbosch from comment #8)
> (In reply to Ajay Gupta from comment #7)
> > This bug is a duplicate of
> > https://bugzilla.mozilla.org/show_bug.cgi?id=1120236. I just verified that
> > restoring the default search bar does indeed fix the problem.
> 
> That bug doesn't affect 34, so that doesn't make a lot of sense...

My bad. This may be a different bug.
(Reporter)

Comment 10

4 years ago
(In reply to :Gijs Kruitbosch from comment #6)
> (In reply to Dutch Kind from comment #5)
> > I have finally discovered where the problem is. I saw that when I delete
> > prefs.js, the problem was gone so I have been removing lines manually from
> > prefs.js until the problem was solved. Appears that when I remove
> > user_pref("browser.startup.homepage",
> > "http://download.opensuse.org/repositories/");
> > the problems is solved. Restoring this line gives the problem. Any idea why
> > this goes wrong? I guess I have had this line in my profile for quite some
> > time and suddenly it gives a problem.
> 
> I don't know how that could in any way be relating to password/autocomplete
> issues.
> 
> If you create a new profile, verify that username/password autocomplete
> works, and then add that line to prefs.js, does that break it in the new
> profile?

I created a new profile from an older firefox I still had in virtualbox. There I was not able to reproduce the bug. I then stripped my problem profile from ff 33, removed all addons and removed all lines to any addon from prefs.js. The problem was still there. Remove the previously mentioned line, problem solved. Now I copied the removed line back in the now working and updated to 34 profile, problem returns.

I don't know how this works, and if there are no other users having a similar problem, let's just close this bug and move on, I certainly know now how to solve it.

Comment 11

4 years ago
Odd... I can mark this as WFM, but adding that line to a clean profile doesn't trigger the bug for me. :-\
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.