[Keyboard] Long-tap key options track above option's actual location

RESOLVED INVALID

Status

RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: ckreinbring, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.1 unaffected, b2g-v2.2 affected)

Details

(URL)

(Reporter)

Description

4 years ago
Description:
If a user attempts to apply an alternate key from one of the regular keys, the alternates will track above where the user's finger is pressing.
   
Repro Steps:
1) Update a Flame device to BuildID: 20141208124704
2) Launch an app that has a keyboard (eg Messaging or Contacts).
3) Navigate to and tap on a textbox, launching the keyboard.
4) Long tap a key that will have accent options (eg a or e).
5) Move your finger over the options and observe the highlight's reaction.
  
Actual:
The accent option above the finger's actual location is highlighted.
  
Expected: 
The accent option at the finger's actual location is highlighted.
  
Environmental Variables:
Device: Flame 2.2 Master
BuildID: 20141208124704
Gaia: bd4dcc8c4582e2368b47b0e62506d3031fb2fc09
Gecko: f1f48ccb2d4e
Platform Version: 37.0a1
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
  
Repro frequency: 100%
See attached video clip
(Reporter)

Comment 1

4 years ago
The bug does not repro on Flame 2.1 engineering with shallow flash.
Actual result: If the user moves their finger over the alternate key stripe, the highlight will follow the finger's actual location.

BuildID: 20141209014645
Gaia: 89421df25ca321f2f4c152dd6e2146cf18b00f06
Gecko: 74fd011aacbf
Platform Version: 34.0
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.1: --- → unaffected
Flags: needinfo?(jmitchell)
Keywords: regression
NI to Keyboard component owner for a blocking decision; notes: This is a regression
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(gchang)
NI developer for this.
Flags: needinfo?(gchang) → needinfo?(rlu)
This is by design, see the latest spec, p.19,
https://bug983043.bugzilla.mozilla.org/attachment.cgi?id=8522035#19
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(rlu)
Resolution: --- → INVALID
Keywords: regression
You need to log in before you can comment on or make changes to this bug.