KeyError: 'changeset' when running mozregression

RESOLVED DUPLICATE of bug 1106258

Status

Testing
mozregression
RESOLVED DUPLICATE of bug 1106258
3 years ago
3 years ago

People

(Reporter: vaibhav1994, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
I ran this on commandline:

    (mozenv)vaibhav@vaibhav:~/mozregression$ mozregression -g 2014-11-26 -b 2014-11-27

     0:09.09 LOG: MainThread Bisector INFO Got as far as we can go bisecting nightlies...
     0:09.09 LOG: MainThread Bisector INFO Ensuring we have enough metadata to get a pushlog...
     0:10.82 LOG: MainThread Bisector INFO Last good revision: ced1402861b8 (2014-11-26)
     0:10.82 LOG: MainThread Bisector INFO First bad revision: cef590a6f946 (2014-11-27)
     0:10.82 LOG: MainThread Bisector INFO Pushlog:
    https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=ced1402861b8&tochange=cef590a6f946
     
     0:10.82 LOG: MainThread Bisector INFO ... attempting to bisect inbound builds (starting from previous week, to make sure no inbound revision is missed)
    Traceback (most recent call last):
      File "/home/vaibhav/mozregression/mozenv/bin/mozregression", line 9, in <module>
        load_entry_point('mozregression==0.30', 'console_scripts', 'mozregression')()
      File "/home/vaibhav/mozregression/mozregression/regression.py", line 463, in cli
        app()
      File "/home/vaibhav/mozregression/mozregression/regression.py", line 243, in bisect_nightlies
        self.last_good_revision = infos['changeset']
    KeyError: 'changeset'
It looks like the changes in bug 1106258 caused this :( Not sure how this was missed.
This is being handled in bug 1106258.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1106258
You need to log in before you can comment on or make changes to this bug.