crash in _PR_MD_SEND | SocketSend | SocketWrite | PR_SetPollableEvent | nsSocketTransportService::OnDispatchedEvent(nsIThreadInternal*)

RESOLVED DUPLICATE of bug 662330

Status

()

Core
Networking: HTTP
--
critical
RESOLVED DUPLICATE of bug 662330
3 years ago
2 years ago

People

(Reporter: lizzard, Unassigned)

Tracking

({crash, topcrash})

34 Branch
x86
Windows NT
crash, topcrash
Points:
---

Firefox Tracking Flags

(firefox34+ wontfix, firefox35+ wontfix, firefox36+ fixed, firefox37+ fixed)

Details

(crash signature)

[Tracking Requested - why for this release]:

[Tracking Requested - why for this release]:

This bug was filed from the Socorro interface and is 
report bp-06101d1f-4c53-4841-b67d-43e922141208.
=============================================================

This is the #9 topcrash for 34.0.5 with 233/11721 crashes in the last 7 days.
It is often a startup crash. It's showing up in significant volume on 34.0b1 as well.  Comments express frustration with repeated startup crashes. Top urls are about:home, about:blank, about:sessionrestore. 

More reports: https://crash-stats.mozilla.com/report/list?product=Firefox&signature=_PR_MD_SEND+|+SocketSend+|+SocketWrite+|+PR_SetPollableEvent+|+nsSocketTransportService%3A%3AOnDispatchedEvent%28nsIThreadInternal*%29 

Crashing thread:

0 		@0xf4e84320 	
1 	nss3.dll 	_PR_MD_SEND 	nsprpub/pr/src/md/windows/w95sock.c
2 	nss3.dll 	SocketSend 	nsprpub/pr/src/io/prsocket.c
3 	nss3.dll 	SocketWrite 	nsprpub/pr/src/io/prsocket.c
4 	nss3.dll 	PR_SetPollableEvent 	nsprpub/pr/src/io/prpolevt.c
5 	xul.dll 	nsSocketTransportService::OnDispatchedEvent(nsIThreadInternal*) 	netwerk/base/src/nsSocketTransportService2.cpp
6 	xul.dll 	nsThread::Dispatch(nsIRunnable*, unsigned int) 	xpcom/threads/nsThread.cpp
7 	xul.dll 	nsSocketTransportService::Dispatch(nsIRunnable*, unsigned int) 	netwerk/base/src/nsSocketTransportService2.cpp
8 	xul.dll 	mozilla::net::nsHttpConnectionMgr::PostEvent(void ( mozilla::net::nsHttpConnectionMgr::*)(int, void*), int, void*) 	netwerk/protocol/http/nsHttpConnectionMgr.cpp
9 	xul.dll 	mozilla::net::nsHttpConnectionMgr::UpdateRequestTokenBucket(mozilla::net::EventTokenBucket*) 	netwerk/protocol/http/nsHttpConnectionMgr.cpp
10 	xul.dll 	mozilla::net::nsHttpHandler::MakeNewRequestTokenBucket() 	netwerk/protocol/http/nsHttpHandler.cpp
11 	xul.dll 	mozilla::net::nsHttpHandler::Init() 	netwerk/protocol/http/nsHttpHandler.cpp
12 	xul.dll 	mozilla::net::nsHttpHandlerConstructor 	netwerk/build/nsNetModule.cpp
13 	xul.dll 	mozilla::GenericFactory::CreateInstance(nsISupports*, nsID const&, void**) 	xpcom/glue/GenericFactory.cpp
14 	xul.dll 	nsComponentManagerImpl::CreateInstance(nsID const&, nsISupports*, nsID const&, void**) 	xpcom/components/nsComponentManager.cpp
15 	xul.dll 	nsComponentManagerImpl::GetService(nsID const&, nsID const&, void**) 	xpcom/components/nsComponentManager.cpp
pretty sure lizzard meant 35.0beta1 where it's currently 31st on the volume list.  but being a startup crasher, it should be weighted more heavily. Particularly since we see it on 33.* and 34.* in our release population.
_PR_MD_SEND usually indicates external interference since bad guys like to hook the system network APIs.

In this case, the reports all have an adware "Wajam Web Enhancer" with a random binary name:
c:\program files\wajam web enhancer\dlls\xqptcfhihqgf.dll
c:\program files\WWE\dlls\ecfgtyorobwr.dll
C:\Program Files\WWE\dlls\repsivndckdw.dll
Tracking for all releases. There is no current plan to ship a point release. We can discuss options once we better understand this crash and whether we can fix it on our end.
status-firefox36: --- → affected
status-firefox37: --- → affected
tracking-firefox34: ? → +
tracking-firefox35: ? → +
tracking-firefox36: --- → +
tracking-firefox37: --- → +
I have also e-mailed Wajam and directed them to this bug report. It is in both of our best interests that this issue be resolved.
Heard back from Wajam. Their engineering team is looking into this issue.
I would be curious to hear Wajam's explanation for why they disguise their DLL name (though I think I know the real reason).
Any updates from Wajam?
Flags: needinfo?(lmandel)
Fwiw, this has fallen out of the top 20 and is at #23 topcrasher in 35.0b
(In reply to Lukas Blakk [:lsblakk] use ?needinfo from comment #8)
> Fwiw, this has fallen out of the top 20 and is at #23 topcrasher in 35.0b

However it is showing as being on the rise...so that's concerning.
I didn't hear back from Wajam again. I sent a follow-up to Wajam about this bug today.
Flags: needinfo?(lmandel)
Nothing actionable for 35 at this point, wontfixing.
status-firefox34: affected → wontfix
status-firefox35: affected → wontfix
Follow-up from Wajam, "The build that fixes this is in QA as of today. It should be live very soon."
Is that only for new Wajam downloads or will existing installations get updated?

> Fwiw, this has fallen out of the top 20 and is at #23 topcrasher in 35.0b
It's possible that we lost the affected users, this being a persistent startup crash.
Flags: needinfo?(lmandel)
(In reply to David Major [:dmajor] (UTC+13) from comment #13)
> Is that only for new Wajam downloads or will existing installations get
> updated?

Word is that a fix will be pushed for new downloads early next week and existing installations will be updated in 2-3 weeks.
Flags: needinfo?(lmandel)
36 & 37 seems to be fixed now.
I guess this bug can be fixed too.
status-firefox36: affected → fixed
status-firefox37: affected → fixed

Updated

3 years ago
Crash Signature: [@ _PR_MD_SEND | SocketSend | SocketWrite | PR_SetPollableEvent | nsSocketTransportService::OnDispatchedEvent(nsIThreadInternal*)] → [@ _PR_MD_SEND | SocketSend | SocketWrite | PR_SetPollableEvent | nsSocketTransportService::OnDispatchedEvent(nsIThreadInternal*)] [@ _PR_MD_SEND | SocketSend | SocketWrite | PR_SetPollableEvent | nsSocketTransportService::OnDispatchedEvent]
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 662330
You need to log in before you can comment on or make changes to this bug.