Closed Bug 1109361 Opened 5 years ago Closed 5 years ago

(FHR) java.util.NoSuchElementException at java.util.Scanner.next(Scanner.java:961) ... ProfileInformationCache.readFromFile(ProfileInformationCache.java:134)

Categories

(Android Background Services Graveyard :: Firefox Health Report Service, defect)

All
Android
defect
Not set

Tracking

(firefox36 fixed, firefox37 fixed)

RESOLVED FIXED
Firefox 37
Tracking Status
firefox36 --- fixed
firefox37 --- fixed

People

(Reporter: mcomella, Assigned: rnewman)

Details

Attachments

(1 file)

Hit a bug in my developer build where Firefox would crash on start-up:

12-09 14:30:37.181 E/GeckoHealthRec( 3631): java.util.NoSuchElementException
12-09 14:30:37.181 E/GeckoHealthRec( 3631):     at java.util.Scanner.next(Scanner.java:961)
12-09 14:30:37.181 E/GeckoHealthRec( 3631):     at java.util.Scanner.next(Scanner.java:934)
12-09 14:30:37.181 E/GeckoHealthRec( 3631):     at org.mozilla.gecko.background.healthreport.ProfileInformationCache.readFromFile(ProfileInformationCache.java:134)
12-09 14:30:37.181 E/GeckoHealthRec( 3631):     at org.mozilla.gecko.background.healthreport.ProfileInformationCache.restoreUnlessInitialized(ProfileInformationCache.java:196)
12-09 14:30:37.181 E/GeckoHealthRec( 3631):     at org.mozilla.gecko.health.BrowserHealthRecorder.initialize(BrowserHealthRecorder.java:516)
12-09 14:30:37.181 E/GeckoHealthRec( 3631):     at org.mozilla.gecko.health.BrowserHealthRecorder.<init>(BrowserHealthRecorder.java:160)
12-09 14:30:37.181 E/GeckoHealthRec( 3631):     at org.mozilla.gecko.BrowserApp.createHealthRecorder(BrowserApp.java:3365)
12-09 14:30:37.181 E/GeckoHealthRec( 3631):     at org.mozilla.gecko.GeckoApp$17.run(GeckoApp.java:1342)
12-09 14:30:37.181 E/GeckoHealthRec( 3631):     at android.os.Handler.handleCallback(Handler.java:733)
12-09 14:30:37.181 E/GeckoHealthRec( 3631):     at android.os.Handler.dispatchMessage(Handler.java:95)
12-09 14:30:37.181 E/GeckoHealthRec( 3631):     at android.os.Looper.loop(Looper.java:136)
12-09 14:30:37.181 E/GeckoHealthRec( 3631):     at org.mozilla.gecko.util.GeckoBackgroundThread.run(GeckoBackgroundThread.java:43)

It's possible that I corrupted my profile as I hit another crash on startup right before this.

Cleared my data which fixed the issue (foolishly - I should have nabbed the profile first).
Thanks for taking the time to file!
Assignee: nobody → rnewman
Status: NEW → ASSIGNED
This implies that the PIC file exists but is empty. We can (and will) band-aid it.
Attached file Proposed patch. v1
Attachment #8540519 - Flags: review?(michael.l.comella)
Comment on attachment 8540519 [details] [review]
Proposed patch. v1

Seems like it would do the trick.
Attachment #8540519 - Flags: review?(michael.l.comella) → review+
https://hg.mozilla.org/mozilla-central/rev/78614247a0b3
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 37
Comment on attachment 8540519 [details] [review]
Proposed patch. v1

Approval Request Comment
[Feature/regressing bug #]:
  Not a regression. Root cause probably crashes during write.

[User impact if declined]:
  Possibility for ongoing failures after a crash.

[Describe test coverage new/current, TBPL]:
  Test added to exercise the scenario.

[Risks and why]: 
  Very low risk: uses existing error handling pathways, just adds one additional check.

[String/UUID change made/needed]:
  None.
Attachment #8540519 - Flags: approval-mozilla-aurora?
Attachment #8540519 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.