Local Folders are gone, replaced by empty folder icon

VERIFIED FIXED

Status

--
blocker
VERIFIED FIXED
17 years ago
10 years ago

People

(Reporter: mscott, Assigned: darin.moz)

Tracking

({dataloss, regression, smoketest})

Trunk
x86
All
dataloss, regression, smoketest

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
We don't have a component for local so picking the next closest thing...pop??? 

On a build pulled around 7:30pm tonight, I picked up a change that caused my
local folders to disappear. Instead of seeing the Local Folders account in the
folder pane, I get blank folder icon with no children. Many JS errors get
triggered if you try to select this blank account.

Comment 1

17 years ago
Same on linux trunk 2001111921
OS: Windows 2000 → All

Comment 2

17 years ago
Here's the JS Console output when I click on the empty space:

Error: [Exception... "Component returned failure code: 0x80004005
(NS_ERRORFAILURE) [nsIMsgFolder.isServer]" nsResult: "0x80004005
(NS_ERROR_FAILURE)  location"JS frame :: 
chrome://messenger/content/mailWindowOverlay.js :: IsGetNewMessageEnabled ::
line 1101" data: no]
Source File: chrome://messenger/content/mailWindowOverlay.js 

Comment 3

17 years ago
Navin, 
I saw this problem on my machine after I pulled today's morning build. I
installed the build before I logged into my pop account I saw this dlg with an
error"
The folder "null" could not be found, so filter(s) associated with this folder
will be disabled.  Verify that the folder exists and the filters point to a
valid destination.  OK

I clicked on the Ok button then I realised that my local folders were gone. In
the thread pane I saw only a folder without name, twisty nothing.  Then I
checked the filters. I saw that my bugzilla filter check box was unchecked and
this had moved down all the way in the list.  
I checked the checked box.  Restarted and the still was not able to recover my
local folder with the same profile

I closed and opened the application with a diffrent build and everything seems
fine. This is seen only from today's build.  

I am adding the keywords and nominating this bug since I see this problem on my
machine too. 
Severity: normal → major
Keywords: nsbeta1, regression

Comment 4

17 years ago
*** Bug 111007 has been marked as a duplicate of this bug. ***

Comment 5

17 years ago
When sending an email, I get an error dialog that says that the send was
successful, but there was a problem copying the file to the sent items folder. 
 (OK or Cancel)
(Reporter)

Comment 6

17 years ago
I get this same error. This is making todays bits pretty hard to send email from
since I get prompted after every sending and none of my sent messages are
getting into my sent folder. 

I think this should have been a smoketest blocker today but the tree is already
open.
Severity: major → blocker
Keywords: dataloss

Comment 7

17 years ago
I am building now....
(Reporter)

Comment 8

17 years ago
This was caused by Darin's check in to nsURLSParser.cpp from yesterday. If I
back out his change we are back in business. Local folders are found again and
messages are properly placed in the sent folder. 
Assignee: naving → darin
Keywords: smoketest
(Reporter)

Comment 9

17 years ago
Here's what you need to back out to get back in business again:

D:\mozilla\netwerk\base\src>cvs up -j 1.3 -j 1.2 nsURLParsers.cpp
RCS file: /cvsroot/mozilla/netwerk/base/src/nsURLParsers.cpp,v
retrieving revision 1.3
retrieving revision 1.2
Merging differences between 1.3 and 1.2 into nsURLParsers.cpp

Comment 10

17 years ago
Scott, backing out nsURLParsers.cpp does solve the problem. 

Comment 11

17 years ago
since the tree is open, feel free to execute the backout. the smoketester must
not use local mail for the sent folder (neither do i, for that matter, which is
why we didn't notice :)

Updated

17 years ago
Blocks: 110998
(Assignee)

Comment 12

17 years ago
OK, i backed out revision 1.3 of nsURLParsers.cpp.
No longer blocks: 110998
(Reporter)

Comment 13

17 years ago
thanks Darin. Let's mark this fixed for now to get it off the radar. 
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 14

17 years ago
also i am crashing when i am changing the location of the Sent folder for
newsgroup ( insetad of Local making it go to one of other accounts), incident ID
# 38294234   

Comment 15

17 years ago
*** Bug 111225 has been marked as a duplicate of this bug. ***

Comment 16

17 years ago
*** Bug 111106 has been marked as a duplicate of this bug. ***

Comment 17

17 years ago
This bug does not exist on today's build anymore. Marking verified.  (build: 
2001-11-26-06)
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.