If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.
Bug 1109434 (SM232-RELNOTE)

Create/Update 2.32 Release Notes

RESOLVED FIXED

Status

Websites
www.seamonkey-project.org
RESOLVED FIXED
3 years ago
9 months ago

People

(Reporter: ewong, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

3 years ago
SeaMonkey 2.32 Beta 1 builds will be built soon.

These relnotes can be (begun to be) prepared ahead of the release date, but need to be out by our first beta release.
(Reporter)

Updated

3 years ago
Alias: SM232-RELNOTE
(Reporter)

Updated

3 years ago
Blocks: 1109435
Assignee: nobody → jh
Status: NEW → ASSIGNED
As y'all probably noticed already, my fighting to find the time to fill in the Changes pages is a losing battle. I wished there was another way, but unless someone else comes around and takes it all over, I need to face reality and stop trying.

So... Starting with this release, there will be no Changes page anymore, and with that, (hopefully) no more "(Coming soon.)" entries. As a partial replacement there will be two new links on the main per-release Release Notes page. These will generate up-to-date lists of SeaMonkey and Thunderbird (including MailNews Core) bugs fixed in the corresponding release.

On the upside, this will make it much easier and quicker to generate/update release notes, because the most time-consuming part - compiling the list of actual changes from the list of hg repository commits - is no more.

On the downside, we lose:
* Detailed, hand-edited lists of only the relevant bug fixes (i.e. those that matter to a user of our product): Bug summaries often leave a lot to be desired concerning understandability for an end-user, and there is no feasible way to automatically and reliably filter out "irrelevant noise" bugs. 
* What's-new-in-this-beta breakdowns: Changes from one beta to the next equal commits to comm-beta. Unfortunately these are not trackable through Bugzilla or in any other non-manual, feasible way.
* Accuracy: Bugzilla queries can only find what has been flagged correctly, whereas the old method of manually checking all comm-central/-aurora/-beta commits against affected source paths allowed to find each and every relevant change.

So in summary this is less than ideal, but something I had to do because for me the only alternative would have been to drop the ball altogether. I also have to point out here that I will not accept any other suggestion if it means more work per release/beta than what I came up with now. Except of course if that extra work will be done by someone else with no need for me to get involved whatsoever. ;-)


Technically I've introduced a new file, changes.tmpl, which helps with generating the necessary Bugzilla queries per release. Matching this there are four extra relnote.var variables, and only these need to be adapted per release. Using those queries, plus the corresponding Firefox release notes, the "What's New" sections can be filled in as usual.


initial version, including new changes template

RCS file: /www/seamonkeyproject-org/lib/changes.tmpl,v
done
Checking in lib/changes.tmpl;
/www/seamonkeyproject-org/lib/changes.tmpl,v  <--  changes.tmpl
initial revision: 1.1
done
RCS file: /www/seamonkeyproject-org/src/releases/seamonkey2.32/index.en.html,v
done
Checking in src/releases/seamonkey2.32/index.en.html;
/www/seamonkeyproject-org/src/releases/seamonkey2.32/index.en.html,v  <--  index.en.html
initial revision: 1.1
done
RCS file: /www/seamonkeyproject-org/src/releases/seamonkey2.32/relnote.var,v
done
Checking in src/releases/seamonkey2.32/relnote.var;
/www/seamonkeyproject-org/src/releases/seamonkey2.32/relnote.var,v  <--  relnote.var
initial revision: 1.1
done
(Reporter)

Updated

3 years ago
Blocks: 1112420
(Reporter)

Updated

3 years ago
Blocks: 1117012
(Reporter)

Updated

3 years ago
Blocks: 1118579
added bug 1114285 to Known Issues

Checking in src/releases/seamonkey2.32/index.en.html;
/www/seamonkeyproject-org/src/releases/seamonkey2.32/index.en.html,v  <--  index.en.html
new revision: 1.3; previous revision: 1.2
done
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED

Comment 3

3 years ago
I'd like to have Bug 1120067 (total RSS update failure) in the Known Issues section of the Release Notes.

With version 2.32 Seamonkey got a major regression. Newly published RSS items are not read and new RSS streams can not be added. 

SM is loosing a key feature because of this. Users should be able to get notice about this fault before their decision to update.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 4

3 years ago
Bug 1120067 - RSS (2.0?) feeds not updating and not being added
has branch approvals pending, thus may still land for 2.32.1.
[leaving bug open anticipating 2.32.1 coming up]

added bug 1069819 and bug 1120067 to Known Issues

Checking in index.en.html;
/www/seamonkeyproject-org/src/releases/seamonkey2.32/index.en.html,v  <--  index.en.html
new revision: 1.4; previous revision: 1.3
done
(Reporter)

Updated

3 years ago
Blocks: 1129269

Comment 6

9 months ago
Due to Bug 616821 comment #7
Assignee: jh → nobody

Comment 7

9 months ago
SM 2.32 was long ago.
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago9 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.