[MCTS] Create non_adb_b2g.py for replacing adb_b2g due to some devices may not have adb

RESOLVED INVALID

Status

RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: atsai, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

User Story

We'll need to use something other than adb_b2g.py for non-adb devices. We assume it's still be able to connect via 2828 port of marionette

Attachments

(1 attachment)

53 bytes, text/x-github-pull-request
atsai
: feedback?
oouyang
Details | Review | Splinter Review
Comment hidden (obsolete)
(Reporter)

Comment 1

4 years ago
Created attachment 8537053 [details] [review]
patches for non-adb devices

I removed most of the parts which are related to adb. The is the general model for non-adb devices. I'll try to add poll_wait mechanism back to non_adb_b2g.py later. Just want to have some feedback before we move forward.
Attachment #8537053 - Flags: feedback?(oouyang)
Attachment #8537053 - Flags: feedback?(jgriffin)
Attachment #8537053 - Flags: feedback?(fyen)
Attachment #8537053 - Flags: feedback?(dave)
(Reporter)

Comment 2

4 years ago
Comment on attachment 8537053 [details] [review]
patches for non-adb devices

Correct owner... my bad
Attachment #8537053 - Flags: feedback?(dave) → feedback?(dminor)

Comment 3

4 years ago
Comment on attachment 8537053 [details] [review]
patches for non-adb devices

Hi Al,

The cert.py tests also use fxos_appgen [1] to generate and install apps with different permissions, so you'll need to replace this as well. I didn't see a bug on file for this.

I can't say for sure, but it might end up being easier to write a replacement for mozdevice that handles talking to the non-adb device rather than replacing all the uses of mozdevice throughout the test suite.

Dan

[1] https://github.com/malini/fxos-appgen
Attachment #8537053 - Flags: feedback?(dminor)
Comment on attachment 8537053 [details] [review]
patches for non-adb devices

This looks like it was designed to run on the device under test, rather than on a separate test machine.  Is that the case for the environment you're trying to support?  Will you be running the suite directly on the device's OS, rather than on a separate laptop?
Attachment #8537053 - Flags: feedback?(jgriffin)
(Reporter)

Comment 5

4 years ago
Suddenly realized that I made a mistake that comment on wrong bugs. Change the title with bug 1109460 :p
Summary: [MCTS] create functions for non-adb devices in cert test → [MCTS] Create non_adb_b2g.py for replacing adb_b2g due to some devices may not have adb
(Reporter)

Updated

4 years ago
User Story: (updated)
(Reporter)

Comment 6

4 years ago
(In reply to Jonathan Griffin (:jgriffin) from comment #4)
> Comment on attachment 8537053 [details] [review]
> patches for non-adb devices
> 
> This looks like it was designed to run on the device under test, rather than
> on a separate test machine.  Is that the case for the environment you're
> trying to support?  Will you be running the suite directly on the device's
> OS, rather than on a separate laptop?

I explained offline and preferred to keep logs here as well.
Since there's no physical device available for now, we'll use the subprocess.Popen() to start a shell command. For Stingray project, it also triggers by commands. We'll modify this line to correct while we have a real device to use.
(Reporter)

Comment 7

4 years ago
Closed as invalid since the code won't land on trunk
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
Attachment #8537053 - Flags: feedback?(fyen)
You need to log in before you can comment on or make changes to this bug.