Closed Bug 1109516 Opened 5 years ago Closed 5 years ago

[Flame][Homescreen]There is a black area covered wallpaper.

Categories

(Core :: Graphics, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1113435
blocking-b2g 2.2+
Tracking Status
b2g-v2.0 --- affected
b2g-v2.0M --- unaffected
b2g-v2.1 --- affected
b2g-v2.2 --- affected

People

(Reporter: lulu.tian, Assigned: BenWa)

References

Details

Attachments

(3 files)

80.88 KB, text/plain
Details
1.46 MB, video/mp4
Details
163.97 KB, text/plain
Details
Attached file logcat
[1.Description]:
[Flame v2.1 & v2.2]
There is a black area displayed at Select wallpaper page and it covers wallpaper.
Found time: 17:49
See attachment: video.MP4 and logcat_1749.txt

[2.Testing Steps]: 
1. Long press at blank area of home screen.
2. Select Change Wallpaper -> Wallpaper.

[3.Expected Result]: 
2. All Wallpapers display correctly and clearly.

[4.Actual Result]: 
2. There is a black area displayed and it covers the wallpaper.

[5.Reproduction build]: 
Flame 2.1 build:
Gaia-Rev        c226db212db4d824c09617cd6dc407b2d4258d9b
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/cf8bebfa4703
Build-ID        20141209170126
Version         34.0

Flame 2.2 build:
Gaia-Rev        4cdeee67b449db90aae9384337311547c280093c
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/d7c76fe69e9a
Build-ID        20141209160204
Version         37.0a1

[6.Reproduction Frequency]: 
Always Recurrence,5/5
TCID: Free Test
Attached video video
Attached file logcat_1423.txt
Hi Eric,
This issue can be repro on Flame 2.0/2.1/2.2, but it can not repro on Woodduck 2.0M, I have uploaded the logcat of Flame 2.2, could you help with it? Thanks!
Found time:14:23
See attachment:logcat_1423.txt

Flame 2.0 build:
Gaia-Rev        f76014fd2c7528493b90d759c68ec3070233d094
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/aedeb9e38bb9
Build-ID        20150106000204
Version         32.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150106.034857
FW-Date         Tue Jan  6 03:49:08 EST 2015
Bootloader      L1TC000118D0

Flame 2.1 build:
Gaia-Rev        b04a8cb7b2482e0a44e6702b48c42283a00b5b1e
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/99cea2c818f6
Build-ID        20150106001308
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150106.034709
FW-Date         Tue Jan  6 03:47:20 EST 2015
Bootloader      L1TC000118D0

Flame 2.2 build:
Gaia-Rev        b77e0d56d197e0ee02d801a25c784130d888c9db
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/2a193b7f395c
Build-ID        20150106010234
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150106.043413
FW-Date         Tue Jan  6 04:34:26 EST 2015
Bootloader      L1TC000118D0

Woodduck build:
Gaia-Rev        06b544f8a9ee03754dd3f5020f279cffa7a75804
Gecko-Rev       6b1e24a1cba1d5542bebb503ce05a1ec61ceb7d3
Build-ID        20150107050313
Version         32.0
Device-Name     jrdhz72_w_ff
FW-Release      4.4.2
FW-Incremental  1420578377
FW-Date         Wed Jan  7 05:06:46 CST 2015
Flags: needinfo?(echang)
* Legacy bug, very visible.
* Suggest to fix this for user experience
blocking-b2g: --- → 2.2?
Flags: needinfo?(echang)
Whiteboard: [systemsfe]
Milan, this seems like a gfx issue. Can you take a look?
Flags: needinfo?(milan)
Looks like a gfx issue with low-res tiles...
Component: Gaia::Homescreen → Graphics
Product: Firefox OS → Core
Whiteboard: [systemsfe]
I'm assuming at related and possibly the same as bug 1113435.
Assignee: nobody → bgirard
Flags: needinfo?(milan)
blocking-b2g: 2.2? → 2.2+
There's a backout of culling on inbound, can we verify if that fixes this issue once it hits central? If it is fixed then we should dupe this against bug 1113435.
Status: NEW → ASSIGNED
See Also: → 1113435
This appears to be fixed
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
See Also: 1113435
Duplicate of bug: 1113435
You need to log in before you can comment on or make changes to this bug.