Closed Bug 1109529 Opened 7 years ago Closed 6 years ago

[Flame][Homescreen]Browser icon couldn't be put into smart collection.

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.1+, b2g-v2.0 unaffected, b2g-v2.1 verified, b2g-v2.1S fixed, b2g-v2.2 verified)

VERIFIED FIXED
2.2 S3 (9jan)
blocking-b2g 2.1+
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.1 --- verified
b2g-v2.1S --- fixed
b2g-v2.2 --- verified

People

(Reporter: liuyong, Assigned: kgrandon)

Details

(Keywords: regression, Whiteboard: [systemsfe])

Attachments

(3 files, 2 obsolete files)

Attached video Smartcollection.MP4
[1.Description]:
[Flame][v2.1&2.2][Homescreen]Browser icon couldn't be put into smart collection.
Found time:23:13
Attachments:Smartcollection.mp4,logcat_2313.txt

[2.Testing Steps]: 
1. Long tap one icon in homescreen.
**Homescreen will skip to edit mode.
2. Press Browser icon and hold on it, put this icon into smart collection.

[3.Expected Result]: 
2. Browser icon should be put into smart collection easily.

[4.Actual Result]: 
2. It can't be put  into smart collection.

[5.Reproduction build]: 
Flame 2.1 build:
Gaia-Rev        c226db212db4d824c09617cd6dc407b2d4258d9b
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/cf8bebfa4703
Build-ID        20141209170126
Version         34.0

Flame 2.2 build:
Gaia-Rev        4cdeee67b449db90aae9384337311547c280093c
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/d7c76fe69e9a
Build-ID        20141209160204
Version         37.0a1

[6.Reproduction Frequency]: 
Always Recurrence,10/10
TCID: Free test
Attached file logcat_2313.txt
NI Homescreen / E.Me owner: is this design?
Flags: needinfo?(mozillamarcia.knous)
Flags: needinfo?(mozillamarcia.knous) → needinfo?(pmathur)
The issue here is that you can put all other apps in the collection such as Calendar, Contacts, Dialer etc...The plus icon appears on the smart collection to indicate that the browser app is being added to the collection but it is not. This is a bug.
Flags: needinfo?(pmathur)
:kgrandon: would you like to comment on this?
Flags: needinfo?(kgrandon)
Let's send it into triage.
blocking-b2g: --- → 2.2?
Flags: needinfo?(kgrandon)
Whiteboard: [systemsfe]
Is this a regression? Lets block on it if its a regression, otherwise lets put it in our backlog.
Keywords: qawanted
It's more likely a regression from 2.0 -> 2.1 that never got caught. My guess is that switching to the system browser is what caused this.
Tested with Shallow Flash on 319mb using Engineering builds.

This bug repro's on Flame KK builds: Flame 2.2 KK, Flame 2.1 KK

Actual Results: Unable to put the browser icon in a collection.

Repro Rate: 6/6

Environmental Variables:
Device: Flame 2.2 KK
BuildID: 20141219033106
Gaia: deb90229734e5397cda806fb11f2e001fba83399
Gecko: 021b09e92d30
Version: 37.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
-----------------------------------------------------------------
Environmental Variables:
Device: Flame 2.1 KK
BuildID: 20141218131205
Gaia: 6af3d029bae3a14f400fec0926f0f8ad7b579b4b
Gecko: d41f6bd64343
Version: 34.0 (2.1) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

-----------------------------------------------------------------
-----------------------------------------------------------------

This bug does NOT repro on Flame kk build: Flame 2.0 KK, Flame v188-1 Base

Actual Result: User is able to add the browser icon to collections.

Environmental Variables:
Device: Flame 2.0 KK
BuildID: 20141218131305
Gaia: ce83ea7b8e3fa2d1c3fd771fc22b654c18b3c381
Gecko: f57067657bfa
Version: 32.0 (2.0) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
-----------------------------------------------------------------
Environmental Variables:
Device: Flame v188-1 Base
BuildID: 20141021162107
Gaia: 8c5c956ee6909408e29f375cc7d843a03d92f3d8
Version: 32.0 (2.0)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawantedregression
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Regression
blocking-b2g: 2.2? → 2.2+
I'll do some initial investigation.
Assignee: nobody → kgrandon
Status: NEW → ASSIGNED
Attachment #8544223 - Attachment is obsolete: true
Attachment #8544224 - Attachment is obsolete: true
Comment on attachment 8544233 [details] [review]
[PullReq] KevinGrandon:bug_1109529_collections_allow_search_role to mozilla-b2g:master

Dale or Cristian - could either of you guys take a look here? Thanks!
Attachment #8544233 - Flags: review?(dale)
Attachment #8544233 - Flags: review?(crdlc)
Comment on attachment 8544233 [details] [review]
[PullReq] KevinGrandon:bug_1109529_collections_allow_search_role to mozilla-b2g:master

Perfect from my side, good job, thanks a lot
Attachment #8544233 - Flags: review?(crdlc) → review+
Comment on attachment 8544233 [details] [review]
[PullReq] KevinGrandon:bug_1109529_collections_allow_search_role to mozilla-b2g:master

Thanks Cristian!
Attachment #8544233 - Flags: review?(dale)
In master: https://github.com/mozilla-b2g/gaia/commit/57c690bb556d4df1daf073a8b57e9f0161affb43
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Is this something that should land on v2.1 as well? If so, please request Gaia v2.1 approval on it :)
Flags: needinfo?(kgrandon)
Target Milestone: --- → 2.2 S3 (9jan)
Comment on attachment 8544233 [details] [review]
[PullReq] KevinGrandon:bug_1109529_collections_allow_search_role to mozilla-b2g:master

I'm not sure because it doesn't have blocking 2.1+ on it, so I'm not sure, though it probably should be uplifted if possible.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): 2.1 system browser chrome implementation.
[User impact] if declined: As described, poor experience with this one use-case in smart collections.
[Testing completed]: Manual and integration testing.
[Risk to taking this patch] (and alternatives if risky): Low risk, simple patch, most of the patch is a test.
[String changes made]: None.
Flags: needinfo?(kgrandon)
Attachment #8544233 - Flags: approval-gaia-v2.1?(bbajaj)
I am changing the blocking status given the regression and given the low risk patch we have to fix this via uplift.
blocking-b2g: 2.2+ → 2.1+
Attachment #8544233 - Flags: approval-gaia-v2.1?(bbajaj) → approval-gaia-v2.1+
Keywords: verifyme
This issue has been verified successfully on Flame 2.2.
Reproducing rate:0/5

Flame2.2 build version:

Gaia-Rev        7c5b27cad370db377b18a742d3f3fdb0070e899f
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/2c37b89bdd86
Build-ID        20150112153951
Version         37.0a2
This issue has been verified successfully on Flame 2.1.
Reproducing rate:0/5

Flame2.1 build version:

Gaia-Rev        8d4846d7bec777046dc5e3d2b8005adb1370f1f7
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/8eb9bc3a945a
Build-ID        20150115001207
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150115.035035
FW-Date         Thu Jan 15 03:50:46 EST 2015
Bootloader      L1TC000118D0
Status: RESOLVED → VERIFIED
Per comment#21, clear the regression, verifyme keywords.
Keywords: regression, verifyme
I deleted “Regression” keyword by personal mistake. Now I specially add this info.
Keywords: regression
You need to log in before you can comment on or make changes to this bug.