Closed Bug 1109539 Opened 8 years ago Closed 8 years ago

[System][Camera] When press the top half of the back button from photo preview in camera app, it easily triggers rocketbar

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v2.1 unaffected, b2g-v2.2 affected)

VERIFIED FIXED
Tracking Status
b2g-v2.1 --- unaffected
b2g-v2.2 --- affected

People

(Reporter: hcheng, Assigned: apastor)

References

()

Details

(Keywords: regression, ux-control, Whiteboard: [systemsfe])

Attachments

(1 file)

*Environment: 
 device: Flame-kk
 build id: 20141209160204

*Description:
When I follow below steps, it is easily to trigger rocketbar after step 3.

*Repro Steps:
1) start camera and take some photos
2) enter photo preview mode.
3) press the top half of the back button to back to camera
I think this is not a defect, but it is easily to trigger rocketbar and not back to camera when I touch the top half of the back button.
Flags: needinfo?(mhabicher)
Keywords: ux-control
I believe this issue extends further than originally reported here.
Within all applications of the phone where the Rocketbar "Search the Web" UI is not visible, tapping in the top-left hand corner where it would be located, the Rocketbar may still be accessed.
Including a video demonstrating the other applications that were considered for this issue: 
Camera, Gallery, Video.

Environmental Variables:
----------------------------------------------
Device: Flame 2.2
BuildID: 20141210040201
Gaia: e17c5656dbf517d48fb61ac9bc92119e023fd717
Gecko: be1f49e80d2d
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 37.0a1 (2.2)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
----------------------------------------------
Repro: 6/6
Video: http://youtu.be/wGUcPKQWRcY

Regarding this bug not being a defect, I can see that in all cases except from the main_screen of the Camera App; there's too much other activity to focus on within the Camera itself with the nature of taking pictures that it wouldn't seem like expected functionality.3
Wilson, is this us? or a component of the system app?
Flags: needinfo?(mhabicher) → needinfo?(wilsonpage)
Looks like system issue to me. The status bar is hidden in Gallery and Camera, but still seems to be responding to touches.
Component: Gaia::Camera → Gaia::System
Flags: needinfo?(wilsonpage)
NI from System Module Owner
Flags: needinfo?(alive)
Summary: [Camera] When press the top half of the back button from photo preview in camera app, it easily triggers rocketbar → [System][Camera] When press the top half of the back button from photo preview in camera app, it easily triggers rocketbar
Is it a regression? Could we get regression window?
Flags: needinfo?(alive)
Whiteboard: [systemsfe]
The bug repros on Flame 2.2 engineering with shallow flash.
Actual result: Tapping in the upper left corner of apps like Gallery and Video will cause the rocketbar to appear.

BuildID: 20141212045251
Gaia: 0de95b4017de73e72c897e2dcb87564d8f3756eb
Gecko: 28fdae830289
Platform Version: 37.0a1
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

--------------------------------------------------------------------------------------------------------

The bug does not repro on Flame 2.1 engineering with shallow flash.
Actual result: Nothing happens when the user taps the upper left corner of apps such as Gallery and Video.

BuildID: 20141210190812
Gaia: 97873dca486abf4162a3345e71b375806937bdec
Gecko: 9faa165ac85d
Platform Version: 34.0
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
QA Contact: ckreinbring
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Regression window
Last working
BuildID: 20141205040650
Gaia: 529c5fcd234ffd108b57629673ca97c2ef73376d
Gecko: 18188c19a3c3
Platform Version: 37.0a1
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

First broken
BuildID: 20141205155833
Gaia: 0e429d970c160e580e19e61ad8ff5612de159f00
Gecko: b1161dda2a6f
Platform Version: 37.0a1
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Working Gaia / Broken Gecko = No repro
Gaia: 529c5fcd234ffd108b57629673ca97c2ef73376d
Gecko: b1161dda2a6f
Broken Gaia / Working Gecko = Repro
Gaia: 0e429d970c160e580e19e61ad8ff5612de159f00
Gecko: 18188c19a3c3
Gaia pushlog: https://github.com/mozilla-b2g/gaia/compare/529c5fcd234ffd108b57629673ca97c2ef73376d...0e429d970c160e580e19e61ad8ff5612de159f00


B2G Inbound
Last working
BuildID: 20141205094246
Gaia: 1fd5166ffb7437ae7b4d6f800cb6d0141b530dfe
Gecko: 084c7e0a3ed7
Platform Version: 37.0a1
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

First broken
BuildID: 20141205105746
Gaia: f7960774b873997a1178ce46855f6605addff020
Gecko: bf693da64f4f
Platform Version: 37.0a1
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Working Gaia / Broken Gecko = No repro
Gaia: 1fd5166ffb7437ae7b4d6f800cb6d0141b530dfe
Gecko: bf693da64f4f
Broken Gaia / Working Gecko = Repro
Gaia: f7960774b873997a1178ce46855f6605addff020
Gecko: 084c7e0a3ed7
Gaia pushlog: https://github.com/mozilla-b2g/gaia/compare/1fd5166ffb7437ae7b4d6f800cb6d0141b530dfe...f7960774b873997a1178ce46855f6605addff020
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
This issue appears to be caused by the patch to  Bug 1105696 - can you take a look Alberto?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(apastor)
QA Contact: ckreinbring
Flags: needinfo?(apastor)
Attachment #8536492 - Flags: review?(kgrandon)
Assignee: nobody → apastor
Duplicate of this bug: 1111019
Blocks: 1105696
Comment on attachment 8536492 [details] [review]
[PullReq] albertopq:1109539-rocketbar-trigger to mozilla-b2g:master

Unfortunately this breaks rocketbar for fullscreen apps. For fullscreen apps you should be able to access rocketbar by dragging down from the top to expose it, then tap on it. I might recommend backing out bug 1105696 and then re-solving the RTL fix.
Attachment #8536492 - Flags: review?(kgrandon) → review-
Yeah, you are right. I'm going to backout bug 1105696 and close this one. Thanks!
Bug that was causing the regression reverted

https://github.com/mozilla-b2g/gaia/commit/350ab351653d77de9030c520aea1108966c1f1d0
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
clear my non-verified bugs

Build ID               20150224162516
Gaia Revision          ca64f2fe145909f31af266b1730874051ba76c78
Gaia Date              2015-02-24 22:06:53
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/16804008c29f
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150224.200438
Firmware Date          Tue Feb 24 20:04:49 EST 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.