’Could not find any existing user to call’ error for loop call

RESOLVED DUPLICATE of bug 1104279

Status

Hello (Loop)
Client
RESOLVED DUPLICATE of bug 1104279
3 years ago
3 years ago

People

(Reporter: Vasilica Mihasca, QA [away for an extended period of time - please needinfo addonsqa@softvision.ro], Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reproducible on: 
Firefox 35 Beta 2 across Windows 7 x64 and Ubuntu 14.04 x32

STR
1.Launch Firefox with a clean profile.
2.Click on Hello Button from toolbar.
3.Click Get Started button.
4.Sign in to your account.
5.Click again on Hello Button and add a new Contact.
6.Hover the Contact.
7.Click on green arrow.
8.Start a Video Conversation/Audio Conversation.

ER
The Conversation starts successfully.

AR
 - "Something went wrong. You can try again or email a link to be reached at later." message appears in pop-up window. 

 - The following error is thrown in browser console: "Loop hawkRequest error:" Object { code: 400, errno: 107, error: "Could not find any existing user to call" } MozLoopService.jsm:519
"HTTP 400 Could not find any existing user to call; undefined" client.js:80
"Failed to get outgoing call data" Object { error: "Could not find any existing user to call", message: undefined, code: 400, errno: 107 } conversationStore.js:365


Additional notes:
 - This issue is reproducible on Firefox 35 Beta 2 (20141208150535) using Windows 7 x64 and Ubuntu 14.04 x32.
 - This is an intermittent issue.
 - Sometimes a browser restarting solves the problem. 
 - I have not encountered this bug using Mac 10.9.5.
Can you please provide the details of what information you're providing when you're adding a contact? I believe the contact needs to be a reachable person and not just some test account.
(In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #1)
> Can you please provide the details of what information you're providing when
> you're adding a contact? I believe the contact needs to be a reachable
> person and not just some test account.

When I add a contact I fill the first 2 fields:

 - Name: with a regular username
 - Email: with a valid and used email address.(yahoo, gmail)

I mention that the user I try to call has a valid loop account and is available.
How intermittent is the issue?
(In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #3)
> How intermittent is the issue?

I managed to isolate more clearly the reproducible steps.
Prerequisites: Login on Loop with 2 users (User A and user B) on 2 different computers.

Follow the next steps:
1. User A initiate conversation to user B => Does not work "Something went wrong. You can try again or email a link to be reached at later." message appears in pop-up window"
2. User B restarts the browser
3. user A tries again to call user B => This time the conversation starts successfully
4. User B initiate conversation to user A => Does not work "Something went wrong. You can try again or email a link to be reached at later." message appears in pop-up window"
5. User A restarts the browser
6. User B tries again to call user A => The call starts successfully

So, we conclude that a user can not call another user until the second user restarts the browser.
The error from Browser Console was caught only a single time.

We were able to reproduce this issue in Firefox 35 Beta 3 using 2 different machines running Windows 7 x64.
Given comment 4, I'm thinking that a shortened summary, is "User logs in and can't receive calls until restart". As a result, this is a duplicate of bug 1104279. Please re-open if I've miss-understood.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1104279
You need to log in before you can comment on or make changes to this bug.