JavaScript - new Date constructor works incorrectly

RESOLVED DUPLICATE of bug 1079720

Status

()

RESOLVED DUPLICATE of bug 1079720
4 years ago
4 years ago

People

(Reporter: ziborov.sasha, Unassigned)

Tracking

34 Branch
x86
Windows 8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.95 Safari/537.36

Steps to reproduce:

1. Open http://jsfiddle.net/3p6yfgn1/ in Firefox 34
2. Open http://jsfiddle.net/3p6yfgn1/ in Internet Explorer 11
3. Compare results.


Actual results:

The "new Date("2014/01/01 00:59:59")" constructor creates Tue Dec 31 2013 23:59:59 GMT+0300 (Russia TZ 2 Standard Time) with -2 hour offset and wrong time zone +0300.


Expected results:

The "new Date("2014/01/01 00:59:59")" constructor creates "Wed Jan 01 2014 00:59:59 GMT+0400 (Russia TZ 2 Daylight Time)"
Component: Untriaged → JavaScript: Standard Library
Product: Firefox → Core

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1079720
You need to log in before you can comment on or make changes to this bug.