[Settings][Rocketbar] Rocketbar search opens up when closing "Terms of Service" or Privacy Notice page

RESOLVED DUPLICATE of bug 1109539

Status

Firefox OS
Gaia::Settings
RESOLVED DUPLICATE of bug 1109539
4 years ago
4 years ago

People

(Reporter: sarsenyev, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.1 affected, b2g-v2.2 affected)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8534483 [details]
closeissuelogcat

Description:
When pressing "X" button to close the "Terms of Services" or the "Privacy Notice" page, the "Rocketbar" search opens up
   
Repro Steps:
1) Update a Flame device to BuildID: 20141210040201
2) Open "Settings" from the home screen
3) Navigate to "Firefox Accounts" and tap the "Create Account or Sign In" bar
4) Tap the "Terms of Service" or the "Privacy Notice" page
5) Close the page by tapping the "x" button
  
Actual:
The "Rocketbar" search opens
  
Expected: 
The page is can be closed when tapping the "x" button and no "rocketbar" appears
  
Flame 2.2

Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141210040201
Gaia: e17c5656dbf517d48fb61ac9bc92119e023fd717
Gecko: be1f49e80d2d
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
  
Notes:
The page is could be closed when tapping a little lower of the "x" button
  
Repro frequency: 90%
See attached: logcat, YouTube video
(Reporter)

Comment 1

4 years ago
The issue DOES REPRO on 2.1
"Rocketbar" is appears when closing the page

"Flame 2.1

Device: Flame 2.1 (319mb) (Kitkat Base)(Full Flash)
Build ID: 20141210001201
Gaia: c226db212db4d824c09617cd6dc407b2d4258d9b
Gecko: cf8bebfa4703
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 34.0 (2.1)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
==================================================================
It doesn't affect 2.0, the "Rocketbar" is integrated in apps starting 2.1
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.1: --- → affected
Flags: needinfo?(dharris)
This behavior seems to happen anywhere in the device as mentioned here: https://bugzilla.mozilla.org/show_bug.cgi?id=1109539#c2

This appears to be a dupe of bug 1109539
Status: NEW → RESOLVED
Last Resolved: 4 years ago
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
Resolution: --- → DUPLICATE
Duplicate of bug: 1109539
You need to log in before you can comment on or make changes to this bug.