Expose the add-on's title in self

RESOLVED WONTFIX

Status

Add-on SDK
General
P2
normal
RESOLVED WONTFIX
4 years ago
3 years ago

People

(Reporter: canuckistani, Assigned: canuckistani)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

We can get the name of the Add-on, but there are cases where it would be good to have read-only access to the title field as well.
Priority: -- → P2
With jpm one can do `require("./package.json").title`
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
Re-opening. I think it's a reasonable argument to say that title should be exposed on self where the rest of the addon's meta-data is. I was going to work on this, fyi.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
changed my mind, you're right. I made a note in the package.json docs on MDN about this.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → WONTFIX
Duplicate of this bug: 1061303
You need to log in before you can comment on or make changes to this bug.