Closed Bug 1109800 Opened 5 years ago Closed 5 years ago

[Settings][Rocketbar] Keyboard pops up when open "Privacy Notice" link

Categories

(Core :: DOM: Selection, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

()

VERIFIED FIXED
mozilla37
blocking-b2g 2.2+
Tracking Status
firefox35 --- wontfix
firefox36 --- wontfix
firefox37 --- fixed
b2g-v2.1 --- unaffected
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: sarsenyev, Assigned: mtseng)

References

()

Details

(Keywords: regression)

Attachments

(2 files, 2 obsolete files)

Attached file keyboardpopsuplogcat
Description:
When open the "Privacy Notice" link from the "Firefox Accounts" page, the keyboard pops up
   
Repro Steps:
1) Update a Flame device to BuildID: 20141210040201
2) Open "Settings" from the home screen
3) Navigate to "Firefox Accounts" and tap the "Create Account or Sign In" bar
4) Tap the "Privacy Notice" page
5) Tap the "Mozilla Privacy Policy" link

  
Actual:
Keyboard pops up when the "Privacy Open" page is open
  
Expected: 
No keyboard pops up when opening the page

Flame 2.2

Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141210040201
Gaia: e17c5656dbf517d48fb61ac9bc92119e023fd717
Gecko: be1f49e80d2d
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
  
Repro frequency: 60% 4/6
See attached: logcat, YouTube video
Couldn't repro the issue on 2.1 

The keyboard doesn't pop up when open the "Privacy Policy" link

"Flame 2.1

Device: Flame 2.1 (319mb) (Kitkat Base)(Full Flash)
Build ID: 20141210001201
Gaia: c226db212db4d824c09617cd6dc407b2d4258d9b
Gecko: cf8bebfa4703
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 34.0 (2.1)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
"
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
Keywords: regression
Nominating 2.2? since this is a regression and an obvious bug that could affect many end users.
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
QA Contact: ckreinbring
Flags: needinfo?(dharris)
Regression window
Last working
BuildID: 20141102092737
Gaia: c2c55870de22d596de4f41612c0b44090f90ebad
Gecko: 0b81c10a9074
Platform Version: 36.0a1
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First broken
BuildID: 20141103035738
Gaia: c2c55870de22d596de4f41612c0b44090f90ebad
Gecko: 667a5bff1599
Platform Version: 36.0a1
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Working Gaia / Broken Gecko = Repro
Gaia: c2c55870de22d596de4f41612c0b44090f90ebad
Gecko: 667a5bff1599
Broken Gaia / Working Gecko = No repro
Gaia: c2c55870de22d596de4f41612c0b44090f90ebad
Gecko: 0b81c10a9074
Gecko pushlog: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=0b81c10a9074&tochange=667a5bff1599


Mozilla Inbound
Last working
BuildID: 20141102230636
Gaia: c2c55870de22d596de4f41612c0b44090f90ebad
Gecko: 14f544cf024a
Platform Version: 36.0a1
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First broken
BuildID: 20141103000037
Gaia: c2c55870de22d596de4f41612c0b44090f90ebad
Gecko: 667a5bff1599
Platform Version: 36.0a1
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Working Gaia / Broken Gecko = Repro
Gaia: c2c55870de22d596de4f41612c0b44090f90ebad
Gecko: 667a5bff1599
Broken Gaia / Working Gecko = No repro
Gaia: c2c55870de22d596de4f41612c0b44090f90ebad
Gecko: 14f544cf024a
Gecko pushlog: http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=14f544cf024a&tochange=667a5bff1599
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
From looking at the pushlog this looks like it might have been broken by Bug 1029943  - Part 1 - Hide selection carets when blurred.  Can you take a look Morris?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(mtseng)
QA Contact: ckreinbring
Confirm this is caused by bug 1029943. Will investigate it.
Flags: needinfo?(mtseng)
This issue because our focus in outer iframe in the beginning, then we click inner iframe's element. So that long tap detector in the SelectionCarets fired incorrectly. I cancel the long tap detector when selection carets are blurred to avoid this issue.
Attachment #8536335 - Flags: review?(roc)
Assignee: nobody → mtseng
Status: NEW → ASSIGNED
Component: Gaia::Settings → Selection
Product: Firefox OS → Core
Removed nsFocusManager change.
Attachment #8536335 - Attachment is obsolete: true
Attachment #8536335 - Flags: review?(roc)
Attachment #8537572 - Flags: review?(roc)
Priority: -- → P2
Blocks: 1111433
Try is good.
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/99f16e6ef426
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla37
Triage: regression blocking.
blocking-b2g: 2.2? → 2.2+
This issue is Verified Fixed for Flame 2.5 and 2.2

Result: Keyboard no longer pops up on privacy page.

Environmental Variables:
Device: Flame 2.5 KK Full Flash (319mb)
Build ID: 20150629134017
Gaia: 27fe0f4261e3685187769411f2f74cff19287b19
Gecko: c26dbd63604d
Gonk: a4f6f31d1fe213ac935ca8ede7d05e47324101a4
Version: 42.0a1 (2.5)

Environmental Variables:
Device: Flame 2.2 KK Full Flash (319mb)
Build ID: 20150629162503
Gaia: b39d4f5b4937592ded19ec65e113a74177ae1f86
Gecko: cefa70ef71e4
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.