search bar no longer shows search provider icon

RESOLVED DUPLICATE of bug 1102922

Status

()

Firefox
Search
RESOLVED DUPLICATE of bug 1102922
3 years ago
3 years ago

People

(Reporter: chris, Unassigned)

Tracking

34 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0
Build ID: 20141126041045

Steps to reproduce:

The search bar used to show the icon of the current search provider. As of version 34, a magnifying glass icon is shown instead. Consequently it's no longer possible to know the default search provider from the search bar's icon alone; instead it's necessary to click the icon and inspect the drop-down, which does show the default provided. If this was an intentional change what is the justification? Why make it harder for the user to know which search provider will be used?

More seriously, the search bar's drop-down no longer changes the default search provider. This may be intentional but it's a nuisance. Changing the default search provider now involves at least five clicks instead of one. Why make it so difficult to changing the default search provider?

Comment 1

3 years ago
I would like to point out that in my honest opinion this change poses serious open/transparency issues. 

You have no idea who or if somebody changed your search provider and what the search provider got changed to. 

In this use case, my firefox downloaded an update and without telling me that it was changing my default search engine did so. It changed it from Google to Yahoo with no prompt and no warning. 

The lack of the icon ensured that you could not see that this change had occurred and where the search results went to.

This is not honest, this is not open, this is not transparent. While Mozilla makes no claim to being honest they generally have harped on their open ness and their transparency. 

This move to further ad revenue from a partner crosses lines that violate that implicit trust one puts in a browser.

Updated

3 years ago
Component: Untriaged → Search

Comment 2

3 years ago
Thanks for the report!

(In reply to chris from comment #0)
> The search bar used to show the icon of the current search provider. As of
> version 34, a magnifying glass icon is shown instead. Consequently it's no
> longer possible to know the default search provider from the search bar's
> icon alone; instead it's necessary to click the icon and inspect the
> drop-down, which does show the default provided. If this was an intentional
> change what is the justification? Why make it harder for the user to know
> which search provider will be used?

It's not so much about "harder to know", it's that until you click the button in the dropdown, it's not clear which engine you will use. If the dropdown icon was for Google/Yahoo/eBay/Amazon/DuckDuckGo/whatever, and you then got a list of other engines underneath it, that would not make logical sense ("why is there a google icon in my yahoo dropdown?").

Note that as soon as you type anything in the box, the dropdown automatically pops up and shows you which provider is used by default (ie if you hit enter / click the arrow button).

Because of this, I don't think we should put the icon back in the search box, so I will close this bug as wontfix.

> More seriously, the search bar's drop-down no longer changes the default
> search provider. This may be intentional but it's a nuisance. Changing the
> default search provider now involves at least five clicks instead of one.
> Why make it so difficult to changing the default search provider?

This is a separate issue. Improving things here is covered in bug 1109851 (as a general rule, please keep 1 bug for 1 issue; I'm adjusting the summary to make very clear that while the icon situation isn't something I think we should change, we are still looking at how to improve setting the default engine / doing multiple searches).

The rationale for the change was that in most cases, we expect people to do 99% of their searches with one search provider (probably (from the default provided set in English, ymmv) Yahoo/Google/Bing/Duckduckgo) and to only use some of the others (wikipedia/amazon/ebay/bugzilla/...) occasionally - as "one off" search providers. It therefore seemed logical to not connect these "one off" searches with changing the default.

Changing the default for the 99% case should really only happen very rarely, and so keeping it in the options seemed the most logical.

People have pointed out that rather than doing 1 search with a different provider, they (to be clear: a specific subset of Firefox users) tended to do 2-10 (or so) searches before switching back the default, and so the current behaviour is not an improvement for them. bug 1109851 is looking at improving this, so please follow up there if you have more questions/suggestions about this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
OS: Windows 7 → All
Hardware: x86_64 → All
Resolution: --- → WONTFIX
Summary: search bar no longer shows search provider icon; drop-down doesn't change default search provider → search bar no longer shows search provider icon

Comment 3

3 years ago
It seems that we're also still trying to address the difficulty of seeing which search engine is the default, so making this bug point to the bug where that's happening probably makes more sense. Sorry for the spam.
Resolution: WONTFIX → DUPLICATE
Duplicate of bug: 1102922
You need to log in before you can comment on or make changes to this bug.