[Calendar] The offline calendar's scheduled events do not automatically update when the timezone is changed

VERIFIED FIXED in 2.2 S5 (6feb)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: jbolton, Assigned: gaye)

Tracking

({regression})

unspecified
2.2 S5 (6feb)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.0 unaffected, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [2.2-flame-reduced-run], URL)

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Description:
The offline calendar's scheduled events do not automatically update when the timezone is changed. If the user has a day with scheduled events highlighted, the user must first tap off of that day and then back on to see the offline calendar events updated with the new timezone.

Repro Steps:
1) Update a Flame device to BuildID: 20141210040201
2) Create an event in the offline calendar- take note of the currently set timezone. Ensure that the day in which the event was created remains highlighted for the following steps.
3) Launch settings and go to date and time.
4) Change the timezone to something different then the currently set timezone (ie. EST vs. PST)
5) Return to the offline calendar, where the day that the event was just created in is still highlighted.
6) Tap off of the selected day.
7) Tap back on to the selected day.
  
Actual:
The offline calendar event times are not updated until the user taps off of the ascribed day with said events and then back on to that day.
  
Expected: 
Offline calendar event times are updated when the timezone is changed.
  
Environmental Variables:
Device: Flame 2.2 Master
BuildID: 20141210040201
Gaia: e17c5656dbf517d48fb61ac9bc92119e023fd717
Gecko: be1f49e80d2d
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.
  
Repro frequency: 100%
See attached: Video, logcat
https://www.youtube.com/watch?v=NjwzDcxWMB8
(Reporter)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
The Flame 2.2 was checked using (319mb)(Full Flash)(Kitkat Base).

QAwanted for branch checks.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
Keywords: qawanted
This issue only occurs on Flame 2.2.

Issue DOES occur
Environmental Variables:
Device: Flame 2.2
BuildID: 20141210035415
Gaia: e17c5656dbf517d48fb61ac9bc92119e023fd717
Gecko: be1f49e80d2d
Version: 37.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0


Issue does NOT occur
Environmental Variables:
Device: Flame 2.1
BuildID: 20141210075316
Gaia: 97873dca486abf4162a3345e71b375806937bdec
Gecko: 07a4ca3db40a
Version: 34.0 (2.1) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Flame 2.0
BuildID: 20141210075212
Gaia: 4887744f873c8aa1ddadd9618e9b79dac259d27d
Gecko: dec2fdd8c4fe
Version: 32.0 (2.0) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Keywords: qawantedregression
Flags: needinfo?(jmitchell)
Nomming for 2.2: Regression, Poor UX

adding Window-wanted tag
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
QA Contact: jmercado
Bug 1027707 seems to have caused this issue.

B2g-inbound Regression Window

Last Working 
Environmental Variables:
Device: Flame 2.2
BuildID: 20141010111807
Gaia: cdfa2f9943a729e7a682212a0ce4d24d965e041e
Gecko: 4e7ad11d7445
Version: 35.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

First Broken 
Environmental Variables:
Device: Flame 2.2
BuildID: 20141010113806
Gaia: 0565fd0735bd353fda9b355c197d9f656907b1b4
Gecko: 4e40a2e933bc
Version: 35.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Last Working gaia / First Broken gecko - Issue does NOT occur
Gaia: cdfa2f9943a729e7a682212a0ce4d24d965e041e
Gecko: 4e40a2e933bc

First Broken gaia / Last Working gecko - Issue DOES occur
Gaia: 0565fd0735bd353fda9b355c197d9f656907b1b4
Gecko: 4e7ad11d7445

Gaia Pushlog: https://github.com/mozilla-b2g/gaia/compare/cdfa2f9943a729e7a682212a0ce4d24d965e041e...0565fd0735bd353fda9b355c197d9f656907b1b4
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
broken by the patch to Bug 1027707 - can you take a look Gareth?
Blocks: 1027707
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(gaye)
QA Contact: jmercado
triage: blocking, this was broken during the AMD conversion.
blocking-b2g: 2.2? → 2.2+
(Assignee)

Updated

4 years ago
Assignee: nobody → gaye
Flags: needinfo?(gaye)
(Assignee)

Updated

4 years ago
Assignee: gaye → jlal
(Assignee)

Updated

4 years ago
Assignee: jlal → gaye
I take it back!
Would like to add a marionette test but unsure about timezone bits. Bug was introduced during refactor (App#startingURL deleted)
Attachment #8556096 - Flags: review?(mmedeiros)
this patch fixes bug 1109850 also
Comment on attachment 8556096 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27759

code changes LGTM. thanks!
Attachment #8556096 - Flags: review?(mmedeiros) → review+
Landed on master https://github.com/mozilla-b2g/gaia/commit/ae5a1580da948c3b9f93528146b007fc4f6a712b
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Please request Gaia v2.2 approval on this when you get a chance.
Flags: needinfo?(gaye)
Target Milestone: --- → 2.2 S5 (6feb)
Comment on attachment 8556096 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27759

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): 1027707
[User impact] if declined: UI won't show correct time for events on the currently selected day after timezone change
[Testing completed]: manual
[Risk to taking this patch] (and alternatives if risky): low risk
[String changes made]: none
Flags: needinfo?(gaye)
Attachment #8556096 - Flags: approval-gaia-v2.2?
Attachment #8556096 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This bug has been verified as "pass" on latest Nightly build of Flame v2.2&3.0 by the STR in Comment 0.

Actual results: Offline calendar event times are updated automatically when the timezone is changed. User needn't tap off of that day and then back on to that day for updating the event time.
See attachment: verified_v2.2&3.0.3gp
Reproduce rate: 0/10


Device: Flame v2.2 build(Verified) 
Build ID               20150628002505
Gaia Revision          0179935627012dfde3ca036c9a71035be463b7ad
Gaia Date              2015-06-26 21:13:44
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/35e09270da3a
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150628.035537
Firmware Date          Sun Jun 28 03:55:48 EDT 2015
Bootloader             L1TC000118D0

Device: Flame v3.0 build(Verified)
Build ID               20150629134017
Gaia Revision          27fe0f4261e3685187769411f2f74cff19287b19
Gaia Date              2015-06-29 14:29:00
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/c26dbd63604d
Gecko Version          42.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150629.170951
Firmware Date          Mon Jun 29 17:10:03 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.