[SMS] Holding onto Send button creates blank area on the screen after keyboard disappears.

RESOLVED DUPLICATE of bug 1106651

Status

()

defect
RESOLVED DUPLICATE of bug 1106651
5 years ago
5 years ago

People

(Reporter: ychung, Assigned: gduan)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
Points:
---

Firefox Tracking Flags

(b2g-v2.1 unaffected, b2g-v2.2 affected)

Details

(Whiteboard: [2.2-flame-reduced-run], )

Attachments

(1 attachment)

Description:
When the user taps and hold the Send button after entering data on the message field, the screen does not recover after the keyboard disappears. Instead, a blank area remains on the screen.
   
Repro Steps:
1) Update a Flame device to BuildID: 20141210040201.
2) Open Messages > New Message.
3) Enter a phone number, and type in data in the Message field.
4) Press and hold the Send button.
  
Actual:
The message is sent, the keyboard disappears, and the black area remains where the keyboard appeared.
  
Expected: 
Either the message is not sent until the user releases the Send button, or the keyboard disappears properly without leaving a blank area.
  
Environmental Variables:
Device: Flame 2.2 Master (319mb, KK, Full Flash)
BuildID: 20141210040201
Gaia: e17c5656dbf517d48fb61ac9bc92119e023fd717
Gecko: be1f49e80d2d
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
  
Repro frequency: 100%
See attached: video clip, logcat
http://youtu.be/oH89NWL27WQ
This issue does NOT reproduce on Flame 2.1.

Result: The message is not sent, and the keyboard does not disappear until the user releases the send button. The black area does not appear after the keyboard disappears.

Device: Flame 2.1 (319mb, KK, Full Flash)
Build ID: 20141210001201
Gaia: c226db212db4d824c09617cd6dc407b2d4258d9b
Gecko: cf8bebfa4703
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 34.0 (2.1)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
[Blocking Requested - why for this release]:

Nominating this to block as this looks bad to the end user, and is normal user flow. Also a regression. Nominating 2.2
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
QA Contact: ckreinbring
I discovered that the key to reproing this bug is making an edge gesture.  This will make the keyboard slide down and leave the black gap.

Regression window
Last working
BuildID: 20141117225025
Gaia: ae3a84acaab80a5b35d5542d63e68462273c8a1b
Gecko: 2a292d225ec0
Platform Version: 36.0a1
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First broken
BuildID: 20141118035325
Gaia: 4aee256937afe9db2520752650685ba61ce6097d
Gecko: f9975ae1e89f
Platform Version: 36.0a1
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Working Gaia / Broken Gecko = No repro
Gaia: ae3a84acaab80a5b35d5542d63e68462273c8a1b
Gecko: f9975ae1e89f
Broken Gaia / Working Gecko = Repro
Gaia: 4aee256937afe9db2520752650685ba61ce6097d
Gecko: 2a292d225ec0
Gaia pushlog: https://github.com/mozilla-b2g/gaia/compare/ae3a84acaab80a5b35d5542d63e68462273c8a1b...4aee256937afe9db2520752650685ba61ce6097d


B2G Inbound
Last working
BuildID: 20141117223226
Gaia: 55fd35fa85a419770764aa48335536f95d3cb833
Gecko: 7ff49b4840e7
Platform Version: 36.0a1
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First broken
BuildID: 20141118001426
Gaia: eed8e507e708a197f139fa5fc5d31fa894a52344
Gecko: adff0e83b260
Platform Version: 36.0a1
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Working Gaia / Broken Gecko = No repro
Gaia: 55fd35fa85a419770764aa48335536f95d3cb833
Gecko: adff0e83b260
Broken Gaia / Working Gecko = Repro
Gaia: eed8e507e708a197f139fa5fc5d31fa894a52344
Gecko: 7ff49b4840e7
Gecko pushlog: https://github.com/mozilla-b2g/gaia/compare/55fd35fa85a419770764aa48335536f95d3cb833...eed8e507e708a197f139fa5fc5d31fa894a52344
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Broken by the patch to Bug 1100195 - can you take a look George?
Blocks: 1100195
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(gduan)
QA Contact: ckreinbring
Assignee: nobody → gduan
Flags: needinfo?(gduan)
I think they are the same bug, so mark it as dup.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1106651
clearing nom due to dupage
No longer blocks: 1100195
blocking-b2g: 2.2? → ---
You need to log in before you can comment on or make changes to this bug.