Forcing news server authentication with username/password

VERIFIED DUPLICATE of bug 39862

Status

VERIFIED DUPLICATE of bug 39862
17 years ago
14 years ago

People

(Reporter: bugzilla, Assigned: racham)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.5) Gecko/20011011
BuildID:    2001101117

I have access to a news server which will give me different levels of use
depending on whether I use a username/password.  If I use no username or
password, it will allow me to log in to the news server, but not to list or
access any groups.  To do this, I need to log in with my username/password.

Mozilla will not allow me to enter a username/password for this news server, as
it detects that it can log in without a u/p, and hence will not allow me to
access any groups.

Netscape (4.76, Win2k) has an option if you right-click on the news server you
are interested in - it allows you to choose from two radio buttons - always ask
for a username/password, and ask for a username/password when necessary. 
Mozilla appears to default to the second option without giving the ability to
change this.

I have asked in the #mozilla chat channel, and other users are unable to find an
option to change this - this suggests it doesn't apply merely to the Windows
version, but I cannot confirm this absolutely.

I have checked with another newsreader (Free Agent) which allows me to specify a
username/password or not - when I do, it asks for one and works perfectly.  When
I don't specify a u/p in Free Agent, it replicates the activity of Mozilla -
logs in but lists no groups.

Reproducible: Always
Steps to Reproduce:
Not really 'reproducable', the option simply appears not to exist anywhere in
the UI.

Comment 1

17 years ago
Stephen, do you know of a bug which covers this case already?
Yes, it's called 'Pushed Authentication', and is fixed via prefs, but currently
has no UI yet.  Bug 39862.

*** This bug has been marked as a duplicate of 39862 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 4

17 years ago
Verified Duplicate.
Status: RESOLVED → VERIFIED
*** Bug 131598 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.