Hitting SIZELIMIT returns no entries?

VERIFIED DUPLICATE of bug 4789

Status

defect
P3
normal
VERIFIED DUPLICATE of bug 4789
20 years ago
20 years ago

People

(Reporter: leif, Assigned: leif)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

I don't know if this is a bug or not, but let's look at it:


From: Steve East <seast@uswest.net>

I'm using PerLDAP 1.2 and running into a problem with sizelimit
processing. I do the following...

$entry = $conn->search($base, "sub", "objectclass=*", 0);
if ($conn->getErrorCode()) {
    return $conn->getErrorString() unless $conn->getErrorCode() ==
                                          LDAP_SIZELIMIT_EXCEEDED;
}
if  (! $entry ) {
    return "no entries returned for search";
} else {

...and get the "no entries returned for search" message. My server
indicates that it returned LDAP_SIZELIMIT_EXCEEDED and 200 entries. I
had assumed I would be able to access those 200 entries? Everything
works fine until I hit the sizelimit.
Status: NEW → ASSIGNED
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
*** This bug has been marked as a duplicate of 4789 ***
cleaning up: VERIFY duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.