search bar autocomplete deletion is broken

RESOLVED DUPLICATE of bug 1083990

Status

()

Firefox
Search
RESOLVED DUPLICATE of bug 1083990
3 years ago
2 years ago

People

(Reporter: Gianluigi Tiesi, Unassigned)

Tracking

34 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:34.0) Gecko/20100101 Firefox/34.0
Build ID: 20141125180439

Steps to reproduce:

I don't remember exactly the version first exposed the problem but maybe 30-31

in the search bar:
type test1 + enter
type test2 + enter

page down in the search bar to delete first entry



Actual results:

second entry is blank, I need to press down key again


Expected results:

second entry is visible and can be deleted

Comment 1

3 years ago
WFM withh FF34 on Win 7, both entries are visible in the drop-down list of the search field.
Did you test with a clean profile?
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

If it started in previous versions, could you use the tool mozregression (http://mozilla.github.io/mozregression/) to find a possible regression range (just copy the changelog, no need to bisect).
Keywords: regressionwindow-wanted
(Reporter)

Comment 2

3 years ago
Created attachment 8534999 [details]
new profile, windows 7, firefox 34.0.5

test1 -> searched
test2 -> searched

page down, deleted test1

Comment 3

3 years ago
I see "test2" after deleting "test1": http://i.imgur.com/2pKVqgK.jpg
Component: Untriaged → Search
(Reporter)

Comment 4

3 years ago
this is very strange it happens every system I try it, just checked on osx, try adding test3, test4 etc

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1083990
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.