resize widget overlaps some window content

VERIFIED DUPLICATE of bug 56488

Status

SeaMonkey
Sidebar
P4
normal
VERIFIED DUPLICATE of bug 56488
17 years ago
14 years ago

People

(Reporter: Stephen Compall, Assigned: Samir Gehani)

Tracking

Trunk
mozilla1.2alpha
PowerPC
Mac System 9.x

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I did a apple-l on os9, and noticed that the big resize icon in the bottom right 
corner overlaps some other widgets. The main Mozilla window does not have this 
problem, but I don't know what other popups might also have this problem.

REPRODUCE:
Open the 'open location...' window in Mac. At least, I think that's where it 
appeared...

FIX:
Force all windows to use that bottom area either as a status bar configured to 
avoid this problem (like the main Moz win), or leave it as blank space.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 1

17 years ago
sorry, the bug is actually in the Customize my Sidebar... dialog

Comment 2

17 years ago
-> sgehani, sidebar customize
Assignee: hyatt → sgehani
Component: XP Toolkit/Widgets → Sidebar
QA Contact: jrgm → sujay
(Assignee)

Updated

17 years ago
Priority: -- → P4
Target Milestone: --- → mozilla0.9.9

Comment 3

17 years ago
This is a far reaching problem that affects many windows:
1. The arrows on the vertical scrollbar in the main browser window is covered by
the grow box when the status bar is turned off and there is no horizontal
scrollbar (This is made worse by the new 'hide toolbar button' on top level windows)
2. The image/cookie manager dialog
3. The form manager and composer 'Advanced Edit' dialogs (bug 100577)
4. The offline indicator in many mail windows including the address book (bug 90489)
5. The 'Customize Sidebar' window (bug 111004)
6. The 'Manage Bookmarks' dialog
7. And probably most other resizable mac windows)

I think that this is a major problem because often important widgets are
covered. UI consistency and correctness is pretty important.
(Assignee)

Comment 4

17 years ago
Sidebar triage team: this dialog should not be resizable since both trees have
scrollbars when necessary.
Target Milestone: mozilla0.9.9 → mozilla1.0

Comment 5

17 years ago
Moving Netscape owned 0.9.9 and 1.0 bugs that don't have an nsbeta1, nsbeta1+,
topembed, topembed+, Mozilla0.9.9+ or Mozilla1.0+ keyword.  Please send any
questions or feedback about this to adt@netscape.com.  You can search for
"Moving bugs not scheduled for a project" to quickly delete this bugmail.
Target Milestone: mozilla1.0 → mozilla1.2

Comment 6

16 years ago
I think this is a dup of bug 56488.

Comment 7

16 years ago
Resolving dup per comment 6. The dialog this was originally reported about no
longer has a resize widget, anyway.

*** This bug has been marked as a duplicate of 56488 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 8

16 years ago
verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.