Closed Bug 1110211 Opened 6 years ago Closed 6 years ago

[gtk3] Atk update

Categories

(Core :: Disability Access APIs, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla37

People

(Reporter: stransky, Assigned: stransky)

References

Details

Attachments

(1 file)

We need to update Platform init code for gtk3, it loads gtk2 libraries now what causes Firefox crash/freeze on start.
Attached patch atk-gtk3.patchSplinter Review
Alexander, can you look at it please? The a11y bridge has been integrated to gtk3 and the module is loaded automatically. But the NO_AT_BRIDGE variable still works, which is used by atk_bridge_adaptor_init().
Attachment #8537218 - Flags: review?(surkov.alexander)
Comment on attachment 8537218 [details] [diff] [review]
atk-gtk3.patch

Review of attachment 8537218 [details] [diff] [review]:
-----------------------------------------------------------------

Trevor might know better this part of code than me. Trev are you ok with review?
Attachment #8537218 - Flags: review?(surkov.alexander) → review?(tbsaunde+mozbugs)
Comment on attachment 8537218 [details] [diff] [review]
atk-gtk3.patch

r? glandium on the really trivial build bits (they lgtm to me though)

This is generally less scary than I thought it might be great
Attachment #8537218 - Flags: review?(tbsaunde+mozbugs)
Attachment #8537218 - Flags: review?(mh+mozilla)
Attachment #8537218 - Flags: review+
Attachment #8537218 - Flags: review?(mh+mozilla) → review+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/2db5144ae9f3
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla37
Well, after having spent time getting elm to build after this change (because at-spi2-atk, which contains atk-bridge wasn't in the gtk3 bundle we used to build), it turns out this adds a runtime dependency on libatk-bridge-2.0.so.0, which isn't available before ubuntu 14.04, and the test slaves run on ubuntu 12.04... I'm afraid this means this needs to be backed out.
Flags: needinfo?(stransky)
Well, the latest Gtk3 is 3.15, recent Fedora one is 3.14. AFAIK Ubuntu 12.04 has 3.6...which is far away from recent gtk3 development. We should pick up some minimal target Gtk3 release but IMHO that version is not even released yet.
Flags: needinfo?(stransky)
Well, the problem is that what we currently have on automation is Ubuntu 12.04. We can't currently test on anything else.
I understand. Is it a solution to add atk-bridge-2.0 for gtk3 > 3.6?
(In reply to Mike Hommey [:glandium] from comment #7)
> Well, after having spent time getting elm to build after this change
> (because at-spi2-atk, which contains atk-bridge wasn't in the gtk3 bundle we
> used to build), it turns out this adds a runtime dependency on
> libatk-bridge-2.0.so.0, which isn't available before ubuntu 14.04, and the
> test slaves run on ubuntu 12.04... I'm afraid this means this needs to be
> backed out.

I'm a little confused how this bundle is possible, I'd expect libgtk-3.so depends on libatk-bridge-2.so as well, and infact on my machine it does.  I wonder what the accessibility story for this setup is, maybe gtk was compiled with some --disable-accessibility option?

However we could certainly remove -latk-bridge-2 and dlsym the symbol we need, but if gtk should bring the dep in anyway that seems silly.
atk-bridge didn't exist before at-spi2-stk 2.5, released in April 2012. The first Gtk release that comes after that date is 3.4, but it doesn't require atk-bridge.
Depends on: 1138845
You need to log in before you can comment on or make changes to this bug.