The secure links on the site do not open.

VERIFIED WORKSFORME

Status

()

Core
Networking: HTTP
VERIFIED WORKSFORME
16 years ago
15 years ago

People

(Reporter: dave, Assigned: Darin Fisher)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.5) Gecko/20011011
BuildID:    2001101117

The CGL-designed shopping cart blows up at the end of a session.
Here's a contact at CGL who researched this when I reported the problem to their
client, The Life Extension Foundation: 

Chris Lambrou
CGL Computer Services, Inc.
http://www.cglcomputer.com

I hope this is useful.  -dave

Chris says:

We found 2 problems with the Mozilla browser:

1. The secure links on the site do not open. Example:
https://www.lef.org/newshop/cgi-shop/payOrder.cgi

If you click on the link above, nothing happens.

2. To access the checkout page, we had to goto
http://www.lef.org/newshop/cgi-shop/payOrder.cgi
(Notice that is "http", not "https")

In which case the sale id changed to "2."  It seems to be an issue with
the browser, as this does not happen with IE 4/5 or Netscape 4.

Reproducible: Always
Steps to Reproduce:
Use the shopping cart at CGL's client, lef.org.
Check out.
After credit card info has been accepted, Moz asks to save form info.
Answer:  no.


Actual Results:  Final screen displays an order summary.
Summary is wrong.
Order Confirmation Number is now "2"
Line items and money are now all wrong.

Expected Results:  Order summary page should display same confirmation # as earlier.
Ditto for order detail.

Sessions with other shopping carts work OK with my configuration.

I only accept originating site cookies.
I'm behind a NAT server.
I run the current freeware versions of ZoneAlarm, WebWasher, and PopUp Killer.
Reporter: 
Have you installed PSM in mozilla ? 
(You must have a SSL Tab under edit/preferences/Privacy&Security)

-> No.1 worksforme

Please try it again with a more recent nightly build :
ftp://ftp.mozilla.org/pub/mozilla/nightly/latest-0.9.6/mozilla-win32-talkback.zip

-> i will not enter my credit card # :-)

Comment 2

16 years ago
wfm using build 2001112006 on Linux.
(Reporter)

Comment 3

16 years ago
RE: Comments From Matti@epost.de  2001-11-20 12:25

I updated to build 2001112001 and used the CGL cart again. It worked.

They have added the following admonishment to the lef.org site:

"Users of beta versions of the Mozilla browser may experience problems with the
Life Extension shopping cart. 
It is recommended that you use either Internet Explorer or Netscape versions 4.x
or above."

I've been using moz on that site more than monthly, since spring.  I'll email
Chris about the sucessful 0.9.6 session, and leave it up to him to test earlier
builds, if he still considers it a Moz problem.

Thanks,
 -dave
worksforme after reporters comment.
(He can open that page..)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 5

15 years ago
Verified WFM.
Status: RESOLVED → VERIFIED
QA Contact: tever → junruh
You need to log in before you can comment on or make changes to this bug.