[Web Audio] Decoding specific .m4a file crashes tab

RESOLVED WORKSFORME

Status

()

Core
Web Audio
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: ashley, Unassigned)

Tracking

({crash, testcase})

33 Branch
x86
Windows 8.1
crash, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.71 Safari/537.36

Steps to reproduce:

Visit this URL: http://www.scirra.com/labs/bugs/audiodecodecrash/

It downloads a file called step1.m4a and attempts to decode it with a Web Audio context.


Actual results:

Tab crashes.


Expected results:

Alert either "Audio decode OK" or "Audio decode error". Chrome reports "Audio decode OK".

Updated

3 years ago
Component: Untriaged → Web Audio
Product: Firefox → Core

Comment 1

3 years ago
On what version of Firefox did you run this? I've tested 33, 34, 35 and 37 (nightly) on OS X, and 37 and 35 on Windows 8.1, and I don't get crashes anywhere. Can you clarify? Thanks!
Flags: needinfo?(ashley)
Keywords: crash, steps-wanted, testcase
(Reporter)

Comment 2

3 years ago
I reported on Windows 8.1 testing with Nightly at the time of posting.  I've tested again on Nightly 37 and I can't reproduce it myself any more, it prompts "Audio decode OK". So I guess it's fixed, or maybe it was some other quirk of Nightly at the time that made it crash? Guess you can close this now.
Flags: needinfo?(ashley)

Comment 3

3 years ago
(In reply to ashley from comment #2)
> I reported on Windows 8.1 testing with Nightly at the time of posting.  I've
> tested again on Nightly 37 and I can't reproduce it myself any more, it
> prompts "Audio decode OK". So I guess it's fixed, or maybe it was some other
> quirk of Nightly at the time that made it crash? Guess you can close this
> now.

Great, thanks for confirming this so quickly!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Keywords: steps-wanted
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.