News: Mark messages all read doesn't work

VERIFIED FIXED in M9

Status

SeaMonkey
MailNews: Message Display
P3
normal
VERIFIED FIXED
19 years ago
a year ago

People

(Reporter: Chris McAfee, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
News, Mark messages all read doesn't seem to
do anything.

Updated

19 years ago
OS: Solaris → All
QA Contact: lchiang → fenella
Hardware: Sun → All

Comment 1

19 years ago
This is probably for all platforms

Comment 2

19 years ago
I've implemented this at the RDF and folder level. In theory, if the db call
MarkAllRead is implemented, this would work for news as well.  When you get a
chance, can you put a milestone on this.
here's why news doesn't work:

mozilla/mailnews/db/msgdb/src/nsNewsDatabase.cpp

nsresult nsNewsDatabase::MarkAllRead(nsMsgKeyArray *thoseMarked)
{
        return NS_ERROR_NOT_IMPLEMENTED;
}

good catch, mcafee.

implementing this now.
Status: NEW → ASSIGNED
Target Milestone: M9
marking m9.
accepting.

and mcafee, thanks for using messenger 5.0 and logging bugs!   keep them coming!
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 6

19 years ago
Linux (1999-08-11-01 M9), Win32 (1999-08-1109 M9)
Mark Message All Read works on News now.
Unable to test Mac. News is broken on Mac.
"News is broken on Mac."

I'm going to need more details than that.

What's broken?  Please open bugs and log them against me.

I'm building the tip right now on my iMac, and I'll test news when its done.

Comment 8

19 years ago
Peter is currently testing on Mac.  He or Par will log new bugs against the Mac
for News.

Comment 9

19 years ago
Logged bug 11749 -[PP] [blocker] News is broken, Can not retrieve news article.
I think this bug may be a duplicate of bug 10797 -[PP][blocker] Necko: Messenger
hangs trying to send or recieve mail.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.