Unable to use email containing apostrophe for user account email

RESOLVED DUPLICATE of bug 415658

Status

()

Bugzilla
User Accounts
RESOLVED DUPLICATE of bug 415658
3 years ago
2 years ago

People

(Reporter: Michael McLean, Unassigned)

Tracking

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.71 Safari/537.36

Steps to reproduce:

I Tried to create an account using an email address containing an apostrophe.


Actual results:

I was prevented from creating an account (through both user self-creation, and admin - add user), with the following error:
"The e-mail address you entered ("Name.O'Name@domain.com")didn't pass our syntax checking for a legal email address. A legal address must contain exactly one '@', and at least one '.' after the @. It also must not contain any illegal characters."


Expected results:

It is expected that the user should be to create an account with a valid email address, even if it contains an apostrophe.

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 415658

Comment 2

2 years ago
Instead of writing only name on login name field please write <User@doamin.local>
I hope issue will be resolve
You need to log in before you can comment on or make changes to this bug.