[FFOS2.0][Woodduck][Call]MS always display incoming call screen and ringing even the remore party already hang up the call.

RESOLVED DUPLICATE of bug 1108520

Status

P2
normal
RESOLVED DUPLICATE of bug 1108520
4 years ago
4 years ago

People

(Reporter: sync-1, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

896.30 KB, image/png
Details
1.17 MB, application/x-rar-compressed
Details
(Reporter)

Description

4 years ago
Created an attachment (id=1064854)
 mtklog
 
 DEFECT DESCRIPTION:
 MS always display incoming call screen and ringing even the remore party already hang up the call.
 
  REPRODUCING PROCEDURES:
 1. Call DUT by a work telephone
 2. Before connected, hung up at MO side
 >DUT would stay at callscreen and ringing
 This issue doesn't occur when dial DUT via a cellphone.
 It is ok on sw7G1A+Zz.not ok on sw7G1b+zz
 
  EXPECTED BEHAVIOUR:
 MS will hang up immediately when the remote party hangup the call.
 >TEL:0752-2611945(61945)
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:
(Reporter)

Comment 1

4 years ago
Created attachment 8535390 [details]
screenshot
(Reporter)

Comment 2

4 years ago
Created attachment 8535391 [details]
mtklog
(Reporter)

Comment 3

4 years ago
this issue occurs after we merged patch MTK v1.1 patch3, maybe the change in dom/system/gonk/ril_worker.js caused this problem. After we reverted modifications here, this issue doesn't occur any more. 
 
 -  _processClassifiedCalls: function(removedCalls, remainedCalls, addedCalls,
 -                                    failCause) {
 +  _processCalls: function(newCalls, failCause) {
 +    // Let's get the failCause first if there are removed calls. Otherwise, we
 +    // need to trigger another async request when removing call and it cause
 +    // the order of callDisconnected and conferenceCallStateChanged
 +    // unpredictable.
 +    if (failCause === undefined) {
 +      for each (let currentCall in this.currentCalls) {
 +        if (!newCalls[currentCall.callIndex] && !currentCall.hangUpLocal) {
 +          this.getFailCauseCode((function(newCalls, failCause) {
 +            this._processCalls(newCalls, failCause);
 +          }).bind(this, newCalls));
 +          return;
 +        }
 +      }
 +    }
(Reporter)

Comment 4

4 years ago
The devices would ask fail cause forever when this issue happens.
QA wanted for a branch check on Woodduck and Flame.
Keywords: qawanted
Kirkland office does not have a land-line; leaving QA-Wanted tag for other offices/labs

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1108520
(Reporter)

Comment 8

4 years ago
Hi Mozilla,
   would you please make 1108520 public or add jz.zhangjin@gmail.com to its CC list? 
   'You are not authorized to access bug #1108520'..

Comment 9

4 years ago
(In reply to sync-1 from comment #8)
> Hi Mozilla,
>    would you please make 1108520 public or add jz.zhangjin@gmail.com to its
> CC list? 
>    'You are not authorized to access bug #1108520'..

Done.
Per Comment 7 (DUPLICATE BUG),clear "qawanted".
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.